WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 5 years ago

#7879 closed defect (bug) (fixed)

media -> Add New needs Delete link after adding

Reported by: DD32 Owned by: azaozz
Milestone: 2.8 Priority: normal
Severity: normal Version: 2.7
Component: Media Keywords: has-patch commit tested
Focuses: Cc:

Description

For consistancy with the post-based uploader, The Media-> Add New page needs a delete link for media that has been accidentally uploaded.

Currently you need to switch over to the Edit screen delete, then back back and upload the correct item.

Attachments (1)

7879_patch.patch (741 bytes) - added by mgriepentrog 5 years ago.

Download all attachments as: .zip

Change History (10)

comment:1 ShaneF6 years ago

  • Owner changed from anonymous to ShaneF
  • Status changed from new to assigned

comment:2 ShaneF5 years ago

  • Owner ShaneF deleted
  • Status changed from assigned to new

comment:3 ShaneF5 years ago

  • Owner set to anonymous

comment:4 westi5 years ago

  • Milestone changed from 2.7 to 2.8

mgriepentrog5 years ago

comment:5 mgriepentrog5 years ago

  • Cc mgriepentrog added
  • Keywords has-patch added; needs-patch removed
  • Owner changed from anonymous to mgriepentrog

The attached patch should address this issue. I was able to verify the fix locally, but I am unsure of what else references this code and if it's important that the delete link be hidden in those cases.

comment:6 ShaneF5 years ago

  • Keywords commit tested added

Although I am against anything now media related for 2.9, this is fine for 2.8 release. tested and working.

comment:7 ryan5 years ago

  • Owner changed from mgriepentrog to azaozz

comment:8 ryan5 years ago

  • Component changed from Administration to Media

comment:9 azaozz5 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [11421]) Show "Delete" in Media -> Add New, props mgriepentrog, fixes #7879

Note: See TracTickets for help on using tickets.