Make WordPress Core

Opened 16 years ago

Closed 16 years ago

Last modified 16 years ago

#7883 closed defect (bug) (worksforme)

build_query() using '&' by default for separator

Reported by: mrasnika's profile Mrasnika Owned by: shanef's profile ShaneF
Milestone: Priority: normal
Severity: normal Version: 2.7
Component: General Keywords: has-patch tested commit
Focuses: Cc:

Description

Hi,

the links produced by get_pagenum_link() when not working with permalinks look like:

http://bg.kaloyan.nova/?cat=10&paged=7

while they should be like:

http://bg.kaloyan.nova/?cat=10&paged=7

I found that this is caused by build_query() using '&' as a default value when composing the query. Can that be changed to '&' instead ? In this way it will produce valid links.

Attachments (1)

7883.1.diff (391 bytes) - added by ShaneF 16 years ago.

Download all attachments as: .zip

Change History (8)

#1 @ShaneF
16 years ago

  • Owner changed from anonymous to ShaneF
  • Status changed from new to assigned

Working on this now.

#2 @ShaneF
16 years ago

  • Milestone changed from 2.8 to 2.7
  • Version set to 2.7

@ShaneF
16 years ago

#3 @ShaneF
16 years ago

  • Keywords has-patch tested commit added

Tested without any problems to permalinks blogs and regular blogs.

#4 @jacobsantos
16 years ago

Okay. This only works well when displaying links on the page.

#5 @ryan
16 years ago

This needs to be changed higher up.

#6 @markjaquith
16 years ago

  • Resolution set to worksforme
  • Status changed from assigned to closed

The functions that echo the links need to run the URL through clean_url()

In the case you mention, it is already so. Please open new tickets if you find other instances of invalid XHTML output.

#7 @thee17
16 years ago

  • Milestone 2.7 deleted
Note: See TracTickets for help on using tickets.