WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#7990 closed defect (bug) (fixed)

"File URL" button not working

Reported by: blonkm Owned by:
Milestone: 2.7 Priority: high
Severity: critical Version: 2.6
Component: General Keywords: IE6 fileurl insert into post
Focuses: Cc:

Description

in IE6, selecting File URL in the media uploader when inserting an image results in the text 'FileURL' instead of in the actual url

Attachments (2)

wp-fileurl-bug-admin.jpg (50.2 KB) - added by blonkm 5 years ago.
wp-fileurl-bug.jpg (24.7 KB) - added by blonkm 5 years ago.

Download all attachments as: .zip

Change History (5)

blonkm5 years ago

blonkm5 years ago

comment:1 blonkm5 years ago

I found the problem, and have a solution as well:

Line 625 of wp-admin/includes/media.php
jQuery('button.url-$post->ID').bind('click', function(){jQuery(this).sib
lings('input').val(this.attributesvalue?.value);});

The problem is that IE reports the innerText of a button as the value attribute, if you don't explicitly tell it to take the attribute from the attributes collection. This does need some cross browser testing, since I am not sure all browser understand the attributes collection.

Still I wonder if this isn't part of jQuery or prototype somewhere.

comment:2 blonkm5 years ago

I now tracked it down in Wordpress.com and to my surprise it has been fixed over there... Does that mean we get it in 2.7???

It shows:
jQuery('button.url-180').bind('click', function(){jQuery(this).siblings('input').val(jQuery(this).attr('title'));});

comment:3 azaozz5 years ago

  • Resolution set to fixed
  • Status changed from new to closed

Yes, the fix is also in 2.6.3.

Note: See TracTickets for help on using tickets.