WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#7991 closed defect (bug) (duplicate)

Quick Edit Broken

Reported by: sc0ttkclark Owned by:
Milestone: Priority: high
Severity: major Version: 2.7
Component: UI Keywords: page edit delete quick
Focuses: Cc:

Description

I created two pages, one "test" and another one "Test".

  • Click Quick Edit on the second page "Test", and the page disappears from view (?)
  • Click Quick Edit on the first page "test", and it works fine.
  • Click Delete on the second page "Test", and the page deletes fine.
  • Click Delete on the first page "test", and it won't delete (?)

Do these in that order and you will see the issues.

Change History (7)

comment:1 sc0ttkclark5 years ago

My apologies, didn't check the formatting before posting, here's the list in a better view:

  1. Click Quick Edit on the second page "Test", and the page disappears from view (?)
  1. Click Quick Edit on the first page "test", and it works fine
  1. Click Delete on the second page "Test", and the page deletes fine
  1. Click Delete on the first page "test", and it won't delete (?)

comment:2 mrmist5 years ago

The "quick edit" issue is more fundamental - you can't quick edit the last post in the list, regardless of its name.

Can't reproduce the delete issue. (in 9386)

comment:3 mrmist5 years ago

  • Summary changed from Create page "test" and then page "Test" - Quick Edit Broke / Unable to Delete Both to Quick Edit Broken

If you start with multiple pages and continue to press quick edit on the last entry in the list until all but one has disappeared, then the last entry gives a javascript error, which, in IE is

line 130 - nodetype is null or not an object

in edit-pages.php.

If you start with one page, pressing quick edit will cause that page to vanish leaving no pages in the list.

comment:4 mrmist5 years ago

Oh, the Posts quick edit screen does not seem to suffer this issue.

comment:5 sc0ttkclark5 years ago

As for the Delete issue happened when I and a colleague (two different accounts) were logged in and created a page called "Test" (different capitalizations between mine and his). Apparently something happened at the time making me unable to delete both. I'm unable to reproduce but I'll keep an eye out incase I figure out the exact bug reproduction steps.

comment:6 mrmist5 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Closing as a dupe of #8044 because that one has a patch attached.

comment:7 mrmist5 years ago

  • Milestone 2.7 deleted
Note: See TracTickets for help on using tickets.