WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#8008 closed defect (bug) (invalid)

Unpublished Pages Can Sometimes Be Viewed

Reported by: DeltaTee Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: General Keywords:
Focuses: Cc:

Description

Pages which have been published and then set back to unpublished can still be viewed on the site by the author, while other users will see the 404 page.

  1. Publish a page
  2. Note the author and guests can see the page on the site.
  3. Change the status to unpublished.
  4. Note the author can still see the page on the site
  5. Note that a guest cannot see the page on the site and gets a 404.

Note: In some cases the guest may forego the 404 page and be sent to a wholly different post which has a similar permalink. (The 404 is still posted, the guest just never sees it.) I still haven't been able to reproduce this reliably though.

Change History (3)

comment:1 westi5 years ago

  • Milestone 2.8 deleted
  • Resolution set to invalid
  • Status changed from new to closed
  • Version 2.6.1 deleted

This is not a bug.

Authors can always see there own posts even if unpublished.

This is how preview mode works.

comment:2 DeltaTee5 years ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

A post which has never been published is viewable as a preview to the author, but attempting to view that post via the slug will return a 404 error. If that post is published and then changed to unpublished, it will be viewable via the slug (by the author only). This inconsistency seems to be a bug.

comment:3 Denis-de-Bernardy5 years ago

  • Resolution set to invalid
  • Status changed from reopened to closed

it's not bug. it's due to the fact that, until you publish, the slug is not around unless you explicitly set it.

Note: See TracTickets for help on using tickets.