Make WordPress Core

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#8024 closed defect (bug) (duplicate)

"Right now" module with not translatable string

Reported by: msi08 Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: I18N Keywords:
Focuses: Cc:


I found some not translatable strings. Currently, it is impossible to translate because poEdit has a problem to detect the strings in their context (other tools will have the same problem, I think). My dashboard is using German and the "Right now" module does not translate the string Posts, Comments, Approved, Spam and Awaiting moderation. The module uses those strings in a singular/plural function but they do exist in a singular context in the language file:

#: /wp-admin/press-this.php:520
#: /wp-admin/edit-form.php:32
#: /wp-admin/includes/dashboard.php:175  # <-- this is the trouble line
#: /wp-admin/includes/dashboard.php:313
msgid "Post"
msgstr "Artikel"

It is not possible to put another "Post/Posts" entry into the language file. poEdit will detect it as double content. My suggestion is to use "_c" and a context. Something like

echo '<td class="t posts">' . _c( __ngettext( 'Post|rightnow', 'Posts|rightnow', $num_posts->publish ) ) . '</td>';

for all those strings in the module to avoid problems with the translation.

Change History (2)

#1 @nbachiyski
7 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #8154.

#2 @jacobsantos
7 years ago

  • Milestone 2.7 deleted
Note: See TracTickets for help on using tickets.