WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#8030 closed defect (bug) (fixed)

Delete page from editor gives erroneous error message

Reported by: dougal Owned by:
Milestone: 2.7 Priority: high
Severity: normal Version: 2.7
Component: Administration Keywords: pages, delete, admin
Focuses: Cc:

Description

When you attempt to delete a page from the editor (not from the 'Edit Pages' listing), you get a screen with nothing but the error message

You attempted to edit a page that doesn't exist. Perhaps it was deleted?

No other navigation elements appear on the page. However, hitting the browser's 'back' button reveals that the page was indeed deleted.

The delete link from the 'Edit Pages' listing functions correctly.

Change History (4)

comment:1 azaozz5 years ago

Looks like a simple redirection problem, after a page has been deleted, it attempts to redirect back to it and since the page doesn't exist any more, it shows the error message.

comment:2 dougal5 years ago

Just checked, and it only happens with pages, not with posts. Just FYI.

comment:3 KirkM5 years ago

I experience the same thing with the latest nightly (via "Stay Updated" link-updated morning of 11-1-08). And I agree, it seems to be attempting to redirect back to ...[site name]/wp-admin/page.php?action=edit&post="same page ID#".

comment:4 westi5 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [9468]) Redirect correctly on page deletion. Fixes #8030.

Note: See TracTickets for help on using tickets.