WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#8077 closed defect (bug) (fixed)

Category Quick Edit does not work

Reported by: navjotjsingh Owned by:
Milestone: 2.7 Priority: normal
Severity: normal Version: 2.7
Component: Administration Keywords:
Focuses: Cc:

Description

I just tested Wordpress 2.7 Beta 2 released to public and found that when you go to category edit page...quick edit on category does not work and the category name gets hidden.

And this problem only occurs on the default category made by Wordpress - Uncategorised.

To reproduce this bug...go to a fresh install of 2.7 beta 2 and try quick edit on Uncategorised.

Though if you create a new category....firstly quick edit button does not display immediately(is this a bug or by design? )..it displays only when page is refreshed. But quick edit for this new category works.

And even if you edit the Uncategorised category the normal way and then afterwards use quick edit...it will still not work.

Quick Edit works for all other categories.

Attachments (1)

patchinlineedit.diff (717 bytes) - added by mrmist 5 years ago.
patch for inline edit

Download all attachments as: .zip

Change History (11)

comment:1 azaozz5 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [9551]) Unhide the Quick Edit link when adding new category by AJAX, fixes #8077

comment:2 azaozz5 years ago

Yes, the missing Quick Edit link can be considered a bug, now fixed. Cannot reproduce the other problem though: editing Uncategorized seems to work well.

comment:3 demetris5 years ago

  • Cc dkikizas@… added
  • Resolution fixed deleted
  • Status changed from closed to reopened

Last category in Posts > Categories still disappears for me when I click Quick Edit.

rev. 9571, two different installations, one with 0 plugins.

The behaviour seems similar to this fixed bug: http://trac.wordpress.org/ticket/8044

comment:4 mrmist5 years ago

Confirmed oddness in 9571. I don't see cats disappear, but rather in Opera the quickedit is doing nothing at all, and in IE also nothin with JS error Syntax error on line 21 reported.

comment:5 azaozz5 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

(In [9588]) Fix QE for the last category, fixes #8077

comment:6 mrmist5 years ago

Fix doesn't seem quite right. See #8141

comment:7 demetris5 years ago

Fix works for me in rev. 9588.

Tested with:

  • Chrome 0.3.154.9
  • Firefox for Windows 3.0.3
  • Firefox for Windows 3.1b2pre (trunk) (where it failed yesterday)
  • IE7
  • Opera for Windows 9.62

comment:8 mrmist5 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

I'm also using 9588 and am seeing no response to hitting quick edit in categories.

Opera 9.51 shows -
Syntax error while loading: line 20 of linked script at [urlremoved]/wp-admin/js/inline-edit-tax.js?ver=20081107 :
Expected statement
<<<<<<< .mine

IE 7 reports syntax error on line 21.

I flushed all the jscript files from the cache to make sure.

In both browsers I now get no response to the quick edit being pressed.

mrmist5 years ago

patch for inline edit

comment:9 mrmist5 years ago

Seems like inlineedit has had weird diff file oddness. I've tried to add a patch that removes the oddness, but I'm not sure what should be in there. It seems to work for me.

comment:10 azaozz5 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

Yes, looks like an unresolved conflict found it's way in. The file has been updates couple of times since, so all should be working well.

Note: See TracTickets for help on using tickets.