WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#8080 closed defect (bug) (worksforme)

Plugin Install - "Latest Version Installed" Incorrect

Reported by: sc0ttkclark Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.7
Component: UI Keywords: reporter-feedback
Focuses: Cc:

Description

If user goes to Install a plugin that's already installed, it says "Latest Version Installed", however the version installed isn't the newest.

For example:

Headspace 3.6 is current version on WordPress.org >> Extend >> Plugins
Headspace 3.5.19 is current version on my WordPress 2.7 installation)

The pop-up page that I get when going to install says, "Latest Version Installed", and that would definitely be incorrect in this situation.

Change History (3)

comment:1 DD325 years ago

  • Keywords reporter-feedback added

Its working for me; for versions 9.0b -> 9.1, and 0.1 -> 1.0, 3.5.19 -> 3.6

Looking at the code that selects the title to display, It works based off the list of plugins which needs an update, If it finds a plugin in there with the same slug, it marks it as needing an update installed.

Disable all other plugins and see if that results in the correct behaviour.

(Btw, The version-changelog warning of that plugin is pretty cool IMO)

comment:2 sc0ttkclark5 years ago

  • Resolution set to worksforme
  • Status changed from new to closed

Weird! Must have a bugged wp 2.7! Sorry

comment:3 jacobsantos5 years ago

  • Milestone 2.7 deleted
Note: See TracTickets for help on using tickets.