WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

#8100 closed defect (bug) (duplicate)

Redirection problem with tags ending in 'p'

Reported by: fitztrev Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: General Keywords:
Focuses: Cc:

Description

When not using permalinks, you cannot access the tag page of any tags ending in 'p'.

http://localhost/?tag=tip is redirecting to http://localhost/?tag=ti

The problem lies with line #207 of wp-inc/canonical.php.

$redirect['query'] = preg_replace( '#&?(p|page_id|cat|tag)=?$#', '', $redirect['query'] );

I am not entirely sure what else the line accomplishes so I won't try to change the regex out of fear of breaking something else.

(per discussion on wp-testers)

Change History (1)

comment:1 @fitztrev7 years ago

  • Milestone 2.7 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #8098

Note: See TracTickets for help on using tickets.