Make WordPress Core

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#8106 closed enhancement (invalid)

Add support for upgrade via SFTP (SSH File Transfer Protocol)

Reported by: Huvet Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.7
Component: Upgrade/Install Keywords: upgrade, sftp, ssh
Focuses: Cc:


To reproduce:

  1. In dashboard: Click Tools -> Update
  2. Fill in SFTP account information
  3. Click proceed

"Error: There was an error connecting to the server, Please verify the settings are correct."

I have verified that the account information is correct by successfully connecting with both FileZilla and PyTTy.

What more information do you need to troubleshoot this further?

Change History (5)

#1 @DD32
7 years ago

try using localhost or for the hostname, see if that helps you.

#2 @Huvet
7 years ago

Same error using either localhost or Anything else I should try?

#3 @Huvet
7 years ago

  • Keywords ssh added
  • Summary changed from Upgrade with SFTP fails in 2.7 beta 2 to Add support for upgrade via SFTP (SSH File Transfer Protocol)
  • Type changed from defect to enhancement

Ah, I see what the problem is, FTPS is not the same as SFTP, silly me. As the title says, I only have access to my host via SFTP, not FTPS (trying that in FileZilla makes the connection fail too).

So this bug is then transformed from a bug to a feature request.

#4 @ryan
7 years ago

  • Milestone 2.8 deleted
  • Resolution set to invalid
  • Status changed from new to closed

2.7 supports SFTP if you have the ssh2 php extension installed.

#5 @Huvet
7 years ago

Thanks, I'll look into that. Would be useful with a note of that on the upgrade page.

Note: See TracTickets for help on using tickets.