WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#8115 closed defect (bug) (fixed)

Quick edit issues in Opera

Reported by: mrmist Owned by:
Milestone: 2.7 Priority: normal
Severity: normal Version: 2.7
Component: General Keywords: has-patch
Focuses: Cc:

Description

Seems to be an issue with Quickedit publish / sticky post.

  1. The "sticky" button has no effect on pending posts (this may be intended, but then the button should be ghosted until valid.)
  1. When a Pending post is atop the edit all posts list, hitting Quick Edit, change from pending to Published, then save sometimes causes the post to vanish from the list, without changing status. This seems to more reliably be a bug with posts that have only recently been submitted for review, so it may be time-dependant. (Bug noted in Opera.) Also note that when this bug stops being a bug, bug 1 also stops.

Attachments (1)

8115.diff (3.3 KB) - added by DD32 6 years ago.

Download all attachments as: .zip

Change History (13)

comment:1 @mrmist6 years ago

These appear to be Opera (9.51) issues, as I can reproduce them whilst at the same time checking in IE where they do not occur.

It is not limited to changes to published status and sticky, it affects all the quick edit functionality for "newish" posts.

comment:2 @mrmist6 years ago

  • Summary changed from Quick edit issues to Quick edit issues in Opera

comment:3 @mrmist6 years ago

  • Keywords needs-patch added

Also reported in Opera 9.61

comment:4 @azaozz6 years ago

  • Keywords reporter-feedback added

When this happens, are there any js errors reported (Tools, Advanced, Error Console, set to show only js errors).

comment:5 @DD326 years ago

I cant reproduce the row disapearing (I reported it in #8137 which is what http://trac.wordpress.org/ticket/8115#comment:3 comment 3 was refering to) after the last few QE commits, But i could reproduce it *every* time yesterday.

The sticky option seems to be sticking too for me right now.

comment:6 @mrmist6 years ago

  • Keywords reporter-feedback needs-patch removed
  • Resolution set to fixed
  • Status changed from new to closed

Agreed both of these are working now as of 9611.

The whole area seems to have changed in design, so I guess one of the intervening changes has sorted it.

comment:7 @DD326 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

Problem has surfaced again today running r9655

No Javascript errors are appearing either.

Cancel works correctly, But clicking Save results in the table row never re-appearing.

comment:8 @azaozz6 years ago

Still can't reproduce this. It seems to resurface every time inline-edit-tax.js is updated. Perhaps Opera hangs on to js files for longer/checks for updates less frequently for them.

Also jQuery suppresses some js errors. For example jQuery('div#mydiv').doSomething won't produce an error if there is no DIV with id="mydiv" on the page but "normal" js would show a type error that "mydiv" is null.

Perhaps adding some debug statements in inline-edit-tax.js would bring more info about what causes this.

comment:9 @mrmist6 years ago

Not seeing the problem at the moment in Opera.

comment:10 @DD326 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

Next time it happens i'll scatter debugging stuff through the files.. Even though i cleared the cache, and even loaded it under a different profile, I couldnt get it to work. Now that i've sat down and gone to debug it, its working perfectly.

@DD326 years ago

comment:11 @DD326 years ago

  • Keywords has-patch added
  • Resolution fixed deleted
  • Status changed from closed to reopened

It appears that the row disapearing (for me at least) was caused by the returned HTML most likely being non-valid, due to PHP Notice's.

attachment 8115.diff checks that the post_parent field is set before using it, Passes the seconds through quick edit (But doesnt show it as a field in QE), and checks that 'keep_private' is in the post data before using it.

comment:12 @azaozz6 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

(In [9712]) QE: fix notices and check if the returned string contains the row HTML, props DD32, fixes #8115

Note: See TracTickets for help on using tickets.