Make WordPress Core

Opened 7 years ago

Closed 7 years ago

#8164 closed defect (bug) (fixed)

Tag suggest suggests Terms from other taxonomies than post_tag

Reported by: DD32 Owned by:
Milestone: 2.7 Priority: normal
Severity: normal Version: 2.5
Component: Taxonomy Keywords: has-patch
Focuses: Cc:


To reproduce:

  • Create a category 'Random Cat'
  • Create a tag 'Random Tag'
  • Start to add a Tag to the post, Type 'Ran', Observe both the Cat and Tag showing up.

The attached patch limits the tag suggest to the 'post_tag' taxonomy

Note: Even if you select a Cat, and attempt to add it to the tag list, While the UI shows its added on the post screen, Upon a refresh, it has not been added to either the Tag list or the Tag list.

Attachments (1)

8164.diff (679 bytes) - added by DD32 7 years ago.

Download all attachments as: .zip

Change History (3)

7 years ago

#1 @DD32
7 years ago

  • Keywords has-patch added
  • Version changed from 2.6.1 to 2.5

(Note, This has been an issue since the Tag suggest feature was introduced in 2.5, [6542], Setting version to reflect that)

#2 @ryan
7 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [9629]) Limit tag suggest to tags. Props DD32. fixes #8164

Note: See TracTickets for help on using tickets.