WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#8173 closed defect (bug) (invalid)

Post slug editor should appear after autosave

Reported by: polite21 Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.7
Component: Administration Keywords: needs-patch
Focuses: Cc:

Description

In 2.5-2.6, you developer people had done it right, with the small dynamic line under the post title field. In 2.7 beta 2, it's back to the 2.3 era meta box rubbish.
I edit the post slug a lot, and I think it was done optimally in 2.5 with the dynamic and easily editable setting above the fold.

From here: http://lorelle.wordpress.com/2008/11/08/wordpress-27-news/#comment-911402
and here: http://wordpress.org/support/topic/214512?replies=5

Change History (18)

comment:1 SimonK5 years ago

It was actually still in the mock-ups like this:

http://wpdotorg.files.wordpress.com/2008/10/newpost.png

comment:2 ionfish5 years ago

  • Milestone 2.7 deleted
  • Priority changed from high to normal
  • Resolution set to invalid
  • Severity changed from major to normal
  • Status changed from new to closed

As of [9633] (the latest revision at the time of writing), post slug editing operates just as it did in 2.5-2.6.

comment:3 SimonK5 years ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

That's just not true, I'm running the latest svn over here and it's in a meta box/widget.

There is actually another bug. When loading the Add Post page for the first time, the slug box is hidden, but the Screen Options pane says it's visible. After ticking the box twice (disabling and enabling it again) it becomes visible at the bottom of the page.

comment:4 ionfish5 years ago

Try saving the post. The slug editor appears under the title. The meta box slug editor is only there in case you want to publish your post without any interim saves, and you can disable it.

comment:5 polite215 years ago

I tried to save the post, or open an already published post, but it never shows to me.
Also, it should appear with the normal autosave feature, like before.
I'm using the svn trunk checked out minutes before I opened this ticket. I'm doing something wrong? I think a normal user should see this like in the previous release.
And in my opinion, this is important to have in the final 2.7 release.

comment:6 ionfish5 years ago

  • Keywords needs-patch added
  • Milestone set to 2.8
  • Summary changed from Post slug editor position to Post slug editor should appear after autosave
  • Type changed from defect to enhancement
  • Version set to 2.7

SimonK: the inconsistent behaviour of the Post Slug metabox is due to a special case added in [6955]: the metabox is hidden automatically if JavaScript is enabled, as the post slug editor beneath the post title will be displayed.

I suggest opening a new ticket to address that issue. I'm renaming this one to more accurately depict the real issue here, which seems to be that the post slug editor should be automatically loaded after the first time a post is saved, even if that is done via the autosave.

comment:7 SimonK5 years ago

I'm confirming what polite21 is seeing, the post slug (or better, permalink interface, there's a difference IMO) below the title never shows up for me. Not on new posts, not on saved posts (drafts), not on published ones.

I also think this is something that should be addressed in 2.7, as our authors (and probably many users all over the world) DID understand the permalink interface, but have absolutely no clue what the slug box does.

comment:8 ionfish5 years ago

I can't reproduce that; have you cleared your browser cache, tried it on different browsers etc.?

The milestone is at 2.8 because there isn't a patch; if someone writes one, this might make it into 2.7 (depending on how the core team feel about this issue), but if they don't, then obviously it won't.

comment:9 SimonK5 years ago

Yep, I primarely use Safari, but I tried Firefox to be sure. It's there though, below the title, but empty, so I'm guessing it's filled by some JS?

<div class="inside">

<div id="edit-slug-box">
</div>

</div>

comment:10 polite215 years ago

Tested opening an already saved draft, I can confirm the empty div in Firefox 3.0.3, Internet Explorer 7, Opera 9.62 on Windows XP.

comment:11 polite215 years ago

It seems that on line 525 in edit-form-advanced.php get_sample_permalink_html($post->ID); returns an empty string.

comment:12 polite215 years ago

Ok, you were right, the problem is that I used a new install from the svn and it was using the default link structure!
Sorry.

comment:13 SimonK5 years ago

Oops. Same over here. I'm gonna go feel stupid in a corner or something.

comment:14 ryan5 years ago

  • Resolution set to invalid
  • Status changed from reopened to closed

comment:15 jacobsantos5 years ago

  • Milestone 2.8 deleted

comment:16 jottlieb5 years ago

  • Milestone set to 2.7
  • Resolution invalid deleted
  • Status changed from closed to reopened
  • Type changed from enhancement to defect

Imho this still is a bug!
Even when you're using the default link structure, you might want to edit your post slug. And the post slug module won't appear although the 'post slug' checkbox in 'screen options' is checked. Only on unchecking and checking the checked checkbox again, this module appears (until you leave the edit page. You have to do that every time, you want to edit the post slug).
And another question is: Why do blogs with permalinks enabled (other link structure) have two ways of editing the post slug (edit permalink and post slug module)?

comment:17 SimonK5 years ago

I think the post slug module is there as a fallback for users without JavaScript.

comment:18 ryan5 years ago

  • Milestone 2.7 deleted
  • Resolution set to invalid
  • Status changed from reopened to closed

Open a new ticket for new issues.

Note: See TracTickets for help on using tickets.