WordPress.org

Make WordPress Core

Opened 12 years ago

Closed 12 years ago

#8191 closed defect (bug) (fixed)

WP2.7 - HTML tags showing in link category descriptions

Reported by: kpdesign Owned by:
Milestone: 2.7 Priority: normal
Severity: normal Version: 2.7
Component: Administration Keywords: has-patch, tested
Focuses: Cc:

Description

HTML tags are being displayed in the description field in the Link Category listing when using the full edit mode.

  • If the description is empty, a line break tag is being shown.
  • If there is a description, it has opening/closing paragraph tags showing.

Editing one link in full edit mode causes the above behaviors to be applied to all links in the list at that time.

Using Quick Edit does not cause this behavior. Opening each link category in Quick Edit and saving causes the HTML tags to disappear for that category.

Attachments (2)

wp2.7-link-cat-errors.png (7.3 KB) - added by kpdesign 12 years ago.
Link Categories listing w/HTML tags showing
edit-link-categories.diff (462 bytes) - added by mrmist 12 years ago.

Download all attachments as: .zip

Change History (14)

@kpdesign
12 years ago

Link Categories listing w/HTML tags showing

#1 follow-up: @DD32
12 years ago

Pretty sure this is a dupe of another ticket, But as usual, I cant find it.

Its caused by _cat_row() double-filtering the category data IIRC.

#2 in reply to: ↑ 1 @kpdesign
12 years ago

Replying to DD32:

Pretty sure this is a dupe of another ticket, But as usual, I cant find it.

My apologies if this is a duplicate. I went through the list of tickets (sorted by ticket number) from the most recent down through around #6500, checking subject lines, and didn't see one with a subject line that seemed to be about this same issue. If you're already aware of it, then I'm sure it will get fixed before the 2.7 final release.

I do know that this does not happen with post categories, only the link categories.

#3 @kpdesign
12 years ago

Just noting that this issue still exists in 2.7 Beta 3.

BTW, I was unable to find a duplicate ticket for this issue either.

#4 @mrmist
12 years ago

Dunno if this fixes the whole issue, but have attached a quick edit.

#5 @mrmist
12 years ago

  • Keywords has-patch needs-testing added

#7 @kpdesign
12 years ago

  • Cc kpdesign added
  • Keywords tested added; needs-testing removed

I've tested the patch by mrmist and found that it resolves the issue for me with the link categories - no HTML tags show after doing a full edit of a category.

I looked at the other ticket ryan referenced, and it seems that poster's issues were linked to a plugin that he is using. My issue did not related to a 3rd-party plugin - this was happening on a default WP install.

#8 @ryan
12 years ago

(In [9740]) Use clone to break object refs when setting and getting cache. see #8146 #8191

#9 @ryan
12 years ago

Does that help?

#10 @mrmist
12 years ago

It seems to have fixed the issue for me.

#11 @kpdesign
12 years ago

Yes Ryan, it fixed the issue for me as well. Thanks!

#12 @ryan
12 years ago

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.