WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#8192 closed defect (bug) (fixed)

2.7 HTML errors

Reported by: arena Owned by:
Milestone: 2.7 Priority: high
Severity: major Version:
Component: Administration Keywords:
Focuses: Cc:

Description

Result: 4 erreurs / 0 avertissements

line 100 column 72 - Erreur: ID "update-plugins" already defined
line 99 column 152 - Info: ID "update-plugins" first defined here
line 111 column 135 - Erreur: character "/" is not allowed in the value of attribute "id"
line 234 column 32 - Erreur: end tag for element "div" which is not open
line 235 column 5 - Erreur: end tag for element "div" which is not open

Erreur: character "/" is not allowed in the value of attribute "id"
coming from my plugin main menu, html generated is :

<li class="wp-has-submenu menu-top toplevel_page_mailpress/mp-admin/mail-new menu-top-first menu-top-last" id="toplevel_page_mailpress/mp-admin/mail-new"><img class="wp-menu-image" src="http://127.0.0.1/wp27/wp-content/plugins/mailpress/mp-admin/images/mblack16x16.png" alt="" /><div class="wp-menu-toggle"><br /></div><a href='admin.php?page=mailpress/mp-admin/mail-new.php' class="wp-has-submenu menu-top toplevel_page_mailpress/mp-admin/mail-new menu-top-first menu-top-last">Mails</a>

Attachments (1)

8192.diff (576 bytes) - added by ryan 5 years ago.

Download all attachments as: .zip

Change History (5)

comment:1 stevish5 years ago

Is this a plugin issue, or something in the core?

comment:2 thee175 years ago

Looks like a plugin issue to me.

comment:3 ryan5 years ago

update-plugins is caused by the update-plugins span being output for both the menu-top and wp-submenu-head cases. A possible fix is to strip tags from the menu name for the wp-submenu-head case.

ryan5 years ago

comment:4 azaozz5 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [9823]) Use css class instead of id to prevent validation errors with multiple instances, fixes #8192

Note: See TracTickets for help on using tickets.