WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

Last modified 3 months ago

#8221 closed defect (bug) (fixed)

Unclickable links in widget editor after adding a widget

Reported by: roganty Owned by:
Milestone: 2.7 Priority: normal
Severity: normal Version: 2.7
Component: UI Keywords: reporter-feedback
Focuses: Cc:

Description

I've recently installed a new theme, but didn't add any widgets.
Today I went to add the widgets, and I can only add one at a time!

When I click on "Add" the widget is added, the yellow box appears saying "Don't forget to save". When the box appears the "Widgets", "Available Widgets" and the bar with the drop down box moves down the page.
The bar with the drop down box moves *under* the list of available widgets.
Some how this renders the "Add" links as unclickable.

I have found two ways to fix this.
The first is add one widget, then save.

The second way is to add a widget, then click on the "Edit" link on the widgets in the "Current Widgets" list.
This then moves the list of available widgets down and the links start working again.

I have attached three screen shots that show this problem.

Attachments (3)

widget_01.png (91.8 KB) - added by roganty 7 years ago.
This screen shot shows the widget editor
widget_02.png (98.7 KB) - added by roganty 7 years ago.
This screen shot shows the widget screen after a widget has been added
widget_03.png (94.9 KB) - added by roganty 7 years ago.
This screen shot shows the same widget screen as in the above screen shot, but with the edit section open

Download all attachments as: .zip

Change History (7)

@roganty7 years ago

This screen shot shows the widget editor

@roganty7 years ago

This screen shot shows the widget screen after a widget has been added

@roganty7 years ago

This screen shot shows the same widget screen as in the above screen shot, but with the edit section open

comment:1 @roganty7 years ago

  • Milestone changed from 2.8 to 2.7

comment:2 @azaozz7 years ago

  • Keywords reporter-feedback added; widget editor ui removed

Cannot reproduce this in FF2 on Linux. Could you also try another browser/OS to confirm if it's browser related.

comment:3 @roganty7 years ago

Cannot reproduce this in FF2 on Linux. Could you also try another browser/OS to confirm if it's browser related.

The browser I was using at the time is Firefox 2.0.0.18 on Linux

I have tried it on XP with both IE 7 and Firefox 3, both did not have the problem.
I then installed Firefox 2.0.0.18 on XP and the problem was still there.

I have also tested it on Opera 9.51 on Linux and the problem was not there.

So it must something to do with Firefox 2.0.0.18

comment:4 @azaozz7 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [9822]) Fix position of "Save widgets settings" warning and problem it causes in Firefox 2, fixes #8221

Note: See TracTickets for help on using tickets.