Make WordPress Core

Opened 7 years ago

Closed 6 years ago

Last modified 5 months ago

#8224 closed defect (bug) (duplicate)

Odd behaviour of tags and category names

Reported by: mrmist Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.7
Component: General Keywords:
Focuses: Cc:


There seems to be some inconsitency around slug names for tags and categories.

If I have a tag with a slug of, say "mytag" -

I go to categories, attempt to edit an existing category and change its slug to "mytag" I'll get an error "category not updated".

I go to categories, attempt to create a new category with slug "mytag" it will create it, and the two entities will then become oddly merged together, changing the display name of one affects the other.

I do not know what - if any - of this is the expected behaviour, but it can't all be right.

Change History (4)

comment:1 @DD327 years ago

I think this may be because of is_term() oddness, Could be related to #6593

comment:2 @markjaquith7 years ago

  • Milestone changed from 2.7 to 2.8

Punting along with #6593

comment:3 @Denis-de-Bernardy6 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Closing as dup of #6593, #5034 and #6211

comment:4 @DrewAPicture5 months ago

  • Milestone 2.8 deleted
Note: See TracTickets for help on using tickets.