WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

#8232 closed defect (bug) (fixed)

Default 'G' Gravatar being shown instead of what's set in the WP options (eg. identicon)

Reported by: johnconners Owned by:
Milestone: 2.7 Priority: normal
Severity: normal Version: 2.7
Component: General Keywords: has-patch needs-testing
Focuses: Cc:

Description

Since picking up [9716] (which is from #8220) I see that the avatar image being shown in either the WP admin pages or a WP2.7 blog should look like:

http://www.gravatar.com/avatar/ecd0449f045e42e66ea24ee9c35788d8?s=32&d=identicon&r=G

but is now being shown as:

http://www.gravatar.com/avatar/ecd0449f045e42e66ea24ee9c35788d8?s=32&d=identicon%3Fs%3D32&r=G

Notice the '%3Fs%3D32' which messed up the URL and when Gravatar attempts to show it for a non-registered user the default 'G' image is returned instead of a generated one. The offending string was added as part of [9716].

Attached is a patch to remove that piece of code again although I'm not entirely sure what the intention of adding it was so I'm hoping this doesn't break something else as a result.

Attachments (2)

8232.diff (506 bytes) - added by johnconners 7 years ago.
8232.2.diff (513 bytes) - added by DD32 7 years ago.

Download all attachments as: .zip

Change History (4)

@johnconners7 years ago

comment:1 @DD327 years ago

That block of code was supposed to add the size param to a custom location (if passed) as the code which was there to do that beforehand seems to no longer be used.

The issue is, That it seems that 'identicon'/'wavatar'/'monsterid' dont have code blocks in the function, so its falling to the else block, and adding a query arg to a string like 'identicon' creates the problem you're seeing.

I'm going to attach a patch that changes it to only affect urls.

@DD327 years ago

comment:2 @azaozz7 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [9728]) Fix default Gravatar URLs, props DD32, fixes #8232

Note: See TracTickets for help on using tickets.