WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#8233 closed defect (bug) (invalid)

comment_reply_link prints a link even when comments are closed

Reported by: ionfish Owned by:
Milestone: Priority: normal
Severity: minor Version: 2.7
Component: Comments Keywords:
Focuses: Cc:

Description

comment_reply_link shouldn't be printing a reply link when comments for that post are closed.

Attachments (1)

8233.diff (568 bytes) - added by ionfish 5 years ago.

Download all attachments as: .zip

Change History (6)

ionfish5 years ago

comment:1 in reply to: ↑ description azaozz5 years ago

  • Severity changed from normal to minor

Replying to ionfish:

comment_reply_link shouldn't be printing a reply link when comments for that post are closed.

And the template should not be calling comment_reply_link() either...

comment:2 ionfish5 years ago

It's called in Walker_Comment, and wp_list_comments() lets theme authors pass in a different class anyway.

comment:3 azaozz5 years ago

get_comment_reply_link() that's echoed from comment_reply_link() returns false when comments are closed, so if there's something returned, the problem is probably somewhere else.

comment:4 ionfish5 years ago

  • Resolution set to invalid
  • Status changed from new to closed

Can't seem to reproduce this issue now. Thanks for your patience Andrew.

comment:5 ionfish5 years ago

  • Milestone 2.7 deleted
Note: See TracTickets for help on using tickets.