WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 6 years ago

Last modified 6 years ago

#8295 closed feature request (duplicate)

Send E-Mail to new user when created from admin section

Reported by: AaronCampbell Owned by: jamierumbelow
Milestone: Priority: normal
Severity: normal Version:
Component: Administration Keywords: needs-patch
Focuses: Cc:

Description

If you create a new user from the admin section, the new user doesn't get an E-Mail notification with their login info.

Change History (8)

comment:1 @filosofo7 years ago

I think this should be plugin material.

In many cases someone will create user accounts on a publicly-inaccessible development site before pushing the site live, or admins and editors will create author accounts that might not need to be accessed by an author in the near future, in which cases you don't want the user to receive an email.

More generally, you don't want to send email that's unintended by the sender (someone just creating an account) and unsolicited by the recipient.

comment:2 @AaronCampbell7 years ago

I'd be ok with that if that's the general consensus. However, it seems unintuitive that the user gets an E-Mail when their account is created by them and not when it's created by admin. If the admin needs to create bogus accounts so bad, have them use a bogus E-Mail. If they want to create an account for a real person and don't want them to know (not sure why you'd do this), have them use a bogus E-Mail or their E-Mail.

comment:3 @ryan7 years ago

  • Type changed from enhancement to feature request

comment:4 @jamierumbelow7 years ago

  • Owner changed from anonymous to jamierumbelow

This is easily do-able, a quick check box saying "do you want to send the user their contact details via email?" would do the trick.

comment:5 @janeforshort6 years ago

  • Milestone changed from 2.8 to 2.9

Agree with Jamie. There should be a built in option to send registration details from admin. The checkbox idea wouldn't do the trick though, because if you're doing pre-setup and don't want the email to go out at the time, but you want to send it when you are ready to go live, there'd be no way to initiate the send. Will work on how this would best be accomplished, pushing to 2.9.

comment:7 @thee176 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Dupe of #9669 which has a patch.

comment:8 @Denis-de-Bernardy6 years ago

  • Milestone 2.9 deleted
Note: See TracTickets for help on using tickets.