WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 23 months ago

Last modified 22 months ago

#8296 closed enhancement (duplicate)

Auto generate password for new user

Reported by: AaronCampbell Owned by: jamierumbelow
Milestone: Priority: normal
Severity: normal Version:
Component: Users Keywords:
Focuses: Cc:

Description

It would be nice to have a button that generates a random password to use when you're creating a new user account in the admin section

Attachments (4)

8296.diff (2.0 KB) - added by solarissmoke 4 years ago.
8296-1.diff (1.7 KB) - added by ericlewis 3 years ago.
Updated version of solarissmoke's implementation, as the current doesn't apply cleanly. Remove AJAX dependency.
8296.2.diff (3.1 KB) - added by SergeyBiryukov 3 years ago.
8296.2.png (13.5 KB) - added by SergeyBiryukov 3 years ago.

Download all attachments as: .zip

Change History (29)

comment:1 @jamierumbelow7 years ago

  • Owner changed from anonymous to jamierumbelow

Good idea - I'll write a patch.

comment:2 @FFEMTcJ6 years ago

  • Milestone changed from 2.8 to Future Release

comment:5 @Denis-de-Bernardy6 years ago

  • Component changed from Administration to Users

comment:6 @cnorris235 years ago

  • Cc cnorris23+wordpress@… added

@solarissmoke4 years ago

comment:8 @solarissmoke4 years ago

  • Keywords has-patch added; needs-patch removed

Patch adds a "generate random password" button to the add user section.

It uses ajax to call wp_generate_password(). We could quite easily generate a password with JS only, but I figured that we should allow the filter in wp_generate_password() to be applied. Open to other opinions however.

comment:9 @solarissmoke4 years ago

PS I haven't added the password generator to user-edit.php on the basis that you would typically want something random only when it is going to be emailed to the user for first use.

Adding a random password generator to user-edit.php feels like asking for trouble, because you just know someone will hit "update" without taking note of the random password.

comment:10 @nacin4 years ago

#9210 has a JS version of wp_generate_password() from sivel.

comment:11 follow-up: @westi4 years ago

Why not just have a check box to send a random password to the user - no need for js or anything?

comment:12 @solarissmoke4 years ago

  • Keywords has-patch removed

That makes sense. Would it be going too far to just remove the manual password altogether and force a random password?

comment:13 @aaroncampbell4 years ago

I'd be happy with "Leave blank to have a password randomly generated" although that doesn't make a lot of sense unless you've also checked the box to "Send this password to the new user by email."

comment:14 @billerickson4 years ago

  • Cc bill.erickson@… added

comment:15 @williamsba13 years ago

  • Cc brad@… added

comment:16 in reply to: ↑ 11 @ericlewis3 years ago

Replying to westi:

Why not just have a check box to send a random password to the user - no need for js or anything?

Is there a large enough user population that has JS disabled, so things like this should be baked into PHP where possible?

Version 0, edited 3 years ago by ericlewis (next)

@ericlewis3 years ago

Updated version of solarissmoke's implementation, as the current doesn't apply cleanly. Remove AJAX dependency.

comment:17 @aaroncampbell3 years ago

  • Cc aaroncampbell added

I definitely like the first patch better (even if it needs a refresh). Using wp_generate_password() which allows filtering makes this more useful (especially on enterprise sites with specific password requirements)

@SergeyBiryukov3 years ago

@SergeyBiryukov3 years ago

comment:18 @SergeyBiryukov3 years ago

8296.2.diff is the refreshed AJAX implementation. "Send this password to the new user by email" is checked automatically when the button is pressed.

Screenshot: 8296.2.png

comment:19 @williamsba13 years ago

I'd love a way to see the password that was generated. There are many occasions when I'm creating accounts for users and I need a record of the password on their account.

comment:20 @billerickson3 years ago

+1 to Brad's comment. Having the ability to view the randomly generated password when created is definitely useful.

When I send a site to a client for review, I create their user, give it a random password, and email their login information along with a lot of other information.

comment:21 @williamsba13 years ago

A good UI example of this is the cPanel password generator. A simple lightbox opens when you click to generate a password shown here:

http://docs.cpanel.net/twiki/bin/view/11_30/CpanelDocs/PasswordGenerator

comment:22 @wedi23 months ago

Right now I'm using this plugin which does it's job great.
http://wordpress.org/plugins/simple-user-password-generator/

Last edited 23 months ago by wedi (previous) (diff)

comment:23 @helen23 months ago

  • Milestone changed from Future Release to 3.7

Seems like this probably goes hand-in-hand with #24633.

comment:24 @wedi23 months ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #24633.

comment:25 @SergeyBiryukov22 months ago

  • Milestone 3.7 deleted
Note: See TracTickets for help on using tickets.