WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 8 months ago

Last modified 8 months ago

#8298 closed defect (bug) (duplicate)

wp_page_menu needs to override wp_list_pages include argument to be functional

Reported by: technosailor Owned by: technosailor
Milestone: Priority: normal
Severity: normal Version: 3.0
Component: Template Keywords: has-patch needs-testing gsoc
Focuses: Cc:

Description

In exploring the new wp_page_menu() function, I realized that there is a byproduct of wp_list_pages that is unintuitive and possibly problematic for people wanting to output a menu. The 'include' argument overrides the use of child_of, parent, meta_key and meta_values parameters.

Menu creation assumes that only some top level pages will need to be used, thus the need for 'include', but wp_list_pages assumes that if you're including only a subset of pages, you're not including the subpages as well. Makes sense on both accounts.

For menu authors, I think expected behavior is that a top level menu would include subpages as well (e.g. a rollover horizontal nav).

I'm submitting a patch that delivers that expected behavior to only the new wp_page_menu() template tag. It reverse engineers the include by using the 'exclude' argument to exclude all pages except the ones passed with the wp_page_menu 'include' argument.

Attachments (3)

8298.diff (921 bytes) - added by technosailor 5 years ago.
8298-2.diff (1020 bytes) - added by technosailor 4 years ago.
8298.2.diff (1.6 KB) - added by wojtek.szkutnik 4 years ago.

Download all attachments as: .zip

Change History (15)

technosailor5 years ago

comment:1 jacobsantos5 years ago

  • Summary changed from wp_page_menu needs to override wp_ist_pages include argument to be functional to wp_page_menu needs to override wp_list_pages include argument to be functional

comment:2 markjaquith5 years ago

  • Milestone changed from 2.7 to 2.8
  • Version set to 2.7

comment:3 Denis-de-Bernardy5 years ago

  • Keywords needs-patch added; template tag pages removed
  • Milestone changed from 2.8 to Future Release

broken patch

comment:4 Denis-de-Bernardy5 years ago

  • Component changed from General to Template

comment:5 Denis-de-Bernardy5 years ago

  • Milestone changed from Future Release to 2.9

comment:6 azaozz4 years ago

  • Milestone changed from 2.9 to Future Release

comment:7 technosailor4 years ago

  • Cc technosailor added
  • Keywords has-patch added; needs-patch removed
  • Status changed from new to assigned
  • Version changed from 2.7 to 3.0

Refreshed patch for 3.0. Can we get this in?

technosailor4 years ago

comment:8 wojtek.szkutnik4 years ago

  • Cc wojtek.szkutnik@… added
  • Keywords needs-testing gsoc added

Was the previous patch working? ('include' vs 'included')
Wasn't it supposed to be looking like the one I am submitting?

wojtek.szkutnik4 years ago

comment:9 hakre3 years ago

Patch still applies clean. Milestone is still on future release, probably something for 3.1?

comment:10 technosailor8 months ago

Duplicate of #12945. Closing

comment:11 technosailor8 months ago

  • Resolution set to wontfix
  • Status changed from assigned to closed

comment:12 SergeyBiryukov8 months ago

  • Milestone Future Release deleted
  • Resolution changed from wontfix to duplicate

Duplicate of #12945.

Note: See TracTickets for help on using tickets.