WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 6 years ago

#8307 closed defect (bug) (duplicate)

Revision timestamps use Server time, not "blog time"

Reported by: nstead Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.7
Component: Administration Keywords: needs-patch
Focuses: Cc:

Description

The post revisions box lists the server times of the revisions, without applying the offset time. All times displayed should be "Blog time" (i.e. the server time offset applied).

Also, the "Draft Saved" time at the bottom of the Post area is server time, not Blog time.

E.g. My Website is UTC (as defined in the General settings page), but my Server time is UTC-6. Editing a post now at 16:23GMT, it shows "Draft Saved at 10:13:26am. Last edited by Neil on November 21, 2008 at 16:05.
If I now save the post, and re-edit it, the post box shows "Last edited by Neil on November 21, 2008 at 16:23", but in the Revisions box, the latest entry is "21 November 2008 @ 10:23". After a minute or so, it saves another draft, and puts "Draft Saved at 10:24:40 am" under the post edit box.

Bug present in 2.7-beta3-9791

Neil.

Change History (2)

comment:1 @westi7 years ago

  • Cc mdawaffe added
  • Keywords needs-patch added
  • Milestone changed from 2.7 to 2.8

I can reproduce this but I am not sure it is a trivial fix and it is without a patch.

I believe this bug also exists in 2.6.x

Moving to 2.8 for now .. will consider for 2.7 if a patch appears.

comment:2 @janbrasna6 years ago

  • Cc janbrasna added
  • Milestone 2.8 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Dupe: #6489

See also: #6520

Note: See TracTickets for help on using tickets.