WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#8337 closed defect (bug) (invalid)

Wordpress 2.6.3 Media gallery tab link is not generated correctly

Reported by: maduranga Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.7
Component: Gallery Keywords: reporter-feedback
Focuses: Cc:

Description

After upgrading to 2.6.3, the Gallery tab's in media gallery under posting, the link does not get properly created aligned with the wp_options settings.

I use a domain forward and with the canonical-redirection-disable plugin, and everything works fine (at least till I upgraded to 2.6.3!).

www.mydomain.com/myblog/wp-admin is the url pattern I am using.

In the gallery tab, the link is there as www.mydomain.com/wp-admin/media-upload.php where as ideally it should have been www.mydomain.com/myblog/wp-admin/media-upload.php

Attachments (1)

gallery-broken-link.png (106.0 KB) - added by maduranga 6 years ago.
Note the status bar link. I have taken this screenshot while mouse is pointed to gallery tab. Ideally the status bar should show me a www.koodos.com/blog/wp-admin... kind of URL. But it shows www.koodos.com/wp-admin/..…

Download all attachments as: .zip

Change History (4)

@maduranga6 years ago

Note the status bar link. I have taken this screenshot while mouse is pointed to gallery tab. Ideally the status bar should show me a www.koodos.com/blog/wp-admin... kind of URL. But it shows www.koodos.com/wp-admin/.....

comment:1 @maduranga6 years ago

  • Component changed from General to Gallery
  • Milestone 2.8 deleted
  • Owner anonymous deleted
  • Priority changed from normal to highest omg bbq
  • Severity changed from normal to major
  • Version set to 2.7

comment:2 @mrmist6 years ago

  • Keywords reporter-feedback added
  • Milestone set to 2.8
  • Priority changed from highest omg bbq to normal
  • Severity changed from major to normal

Is this still an issue in 2.7?

comment:3 @DD326 years ago

  • Milestone 2.8 deleted
  • Resolution set to invalid
  • Status changed from new to closed

If it is, Its a configuration error.

Ensure that the SiteURL and the WordPress URL in your options are set correctly.

Note: See TracTickets for help on using tickets.