Make WordPress Core

Opened 13 years ago

Closed 13 years ago

#8391 closed defect (bug) (invalid)

Infinite login loop in 2.6+ (incl. 2.7-b3)

Reported by: braindrain's profile braindrain Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.6
Component: Administration Keywords:
Focuses: Cc:

Description

On one of the websites I manage, I am currently forced to use version 2.5, rather than either 2.6 or 2.7-b3. I have tried several times to install both of these newer versions for our website, trying scratch installations, upgrades and installing in a folder and moving to the root. In every case, the public part of the site works fine, but whenever I try to access the admin panel, I'm asked to "Please log in again." I know that it thinks I'm already logged in, because of the meta section of the front end sidebar. Also, if I enter an invalid user name/password combination, it will tell me as much.

I am able to install Wordpress in a folder and use it just fine, but whenever I move the installation to the root (copy the files, then change the urls in the admin panel), it goes to the above behavior.

For the record...

  • Versions tried: 2.6, 2.6.1, 2.6.2, 2.7-b3
  • PHP Version: 4.3.9 (yes, I know it's ancient, but I'm kinda stuck with it).
  • Server: Apache 2.0.58 (Red Hat)
  • MySQL: 4.1.20

Change History (5)

#1 in reply to: ↑ description ; follow-up: @polite21
13 years ago

Have you checked all the new AUTH_KEY, SECURE_AUTH_KEY, LOGGED_IN_KEY in your wp-config.php?

#2 in reply to: ↑ 1 @braindrain
13 years ago

Replying to polite21:

Have you checked all the new AUTH_KEY, SECURE_AUTH_KEY, LOGGED_IN_KEY in your wp-config.php?

What do those need to be set to? Also, would that make a difference between an install in a folder and an install in the root of the website?

#3 @mrmist
13 years ago

I suspect this is a browser cookie issue. A sure way of telling would be if you can still log in with a different browser to the one you normally use.

#4 @braindrain
13 years ago

It was a cookie issue. I cleared all the cookies from the website and it worked just fine.

#5 @jacobsantos
13 years ago

  • Milestone 2.7 deleted
  • Resolution set to invalid
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.