WordPress.org

Make WordPress Core

Opened 13 years ago

Closed 8 years ago

#8492 closed defect (bug) (duplicate)

Page name drop-downs do not scale well

Reported by: mrmist Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.7
Component: Administration Keywords: needs-patch
Focuses: performance Cc:

Description

The page title drop-downs on options-reading and page.php seem to scale poorly in page loading times when you have a large number (around 1000) of Pages.

I need to go to bed now so haven't researched this much, but I think the options-reading bit could be improved - I think it's currently fetching all of wp_posts when it only needs the title, which is a fair bit of wasted DB and processing time.

rev 10051 and previous.

Change History (10)

#1 @Denis-de-Bernardy
12 years ago

  • Keywords needs-patch added

+1. get_pages() needs an extra fields param to pick the fields, that would default to *. And post caching should not be enforced (as is done in get_terms()) when fields is not *.

#2 @Denis-de-Bernardy
12 years ago

  • Component changed from General to Optimization

#3 follow-up: @hakre
12 years ago

page.php -> edit page.

but what is options-reading?

#4 @hakre
12 years ago

  • Keywords reporter-feedback added

#5 in reply to: ↑ 3 @Denis-de-Bernardy
12 years ago

  • Keywords dev-feedback added; reporter-feedback removed

Replying to hakre:

The issue is highlighted in my above comment. What happens is, WP retrieves all fields of all pages. as in, absolutely everything. It might just as well get ID, post_title, post_parent instead. This would speed things up.

In get_terms(), there is a means to grab a subset of fields only -- which disables the caching when it's used. get_pages() should probably get the same thing.

#7 @Denis-de-Bernardy
12 years ago

  • Keywords dev-feedback removed
  • Milestone changed from 2.8 to Future Release

punting to future, pending patch

#8 @Denis-de-Bernardy
12 years ago

  • Milestone changed from Future Release to 2.9

#9 @janeforshort
12 years ago

  • Milestone changed from 2.9 to Future Release

Punting due to lack of patch.

#10 @nacin
8 years ago

  • Component changed from Optimization to Administration
  • Focuses performance added
  • Milestone Future Release deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #9864.

Note: See TracTickets for help on using tickets.