WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 6 years ago

#8499 closed enhancement (invalid)

Date and Time logic on the dashboard should be associated with user's date/time settings

Reported by: vanillalounge Owned by:
Milestone: Priority: low
Severity: minor Version: 2.7
Component: Date/Time Keywords: has-patch needs-testing 2nd-opinion
Focuses: Cc:

Description

I've noticed that on some areas of the dashboard, the dates shown are
formatted according to the translation file (<locale>.mo, if it exists).
This is true (at least) on the Pages' and Posts' lists.

My suggestion is that it would make more sense to read the format from
Settings > General > Date Format since right now it can get a bit
confusing for a user having defined a format of, say "Y-m-d" but seing a
format of "Y\d\m" because the .mo says so. This is particularly
pertinent to MU where different users can choose different date and time
formats, but applies to wp.org, mu.org and wp.com.

This certainly has implications on the .pot but I'm not too sure yet on how to patch that.

Attachments (1)

template.php.diff (3.5 KB) - added by vanillalounge 7 years ago.

Download all attachments as: .zip

Change History (12)

@vanillalounge7 years ago

comment:1 @vanillalounge7 years ago

  • Component changed from General to Administration

comment:2 @nbachiyski7 years ago

  • Component changed from Administration to i18n
  • Owner changed from anonymous to nbachiyski

comment:3 @lloydbudd7 years ago

  • Component changed from i18n to Administration
  • Milestone changed from 2.7 to 2.8
  • Owner changed from nbachiyski to anonymous
  • Priority changed from normal to low
  • Severity changed from normal to minor

vanillalounge, thanks for the bug report!

Generally, you should leave the milestone to the default value. In this case, 2.7's ship has sailed for enhancements some time ago.

Moving back to Administration from i18n, because the issue is the same in the non-i18n case.

Many moons ago, I made a near identical patch, but Matt let me know that the setting is for the presentation of the blog, not for the dashboard.

If you search on "Date Format" you will find other related bugs with similar resolutions:

As you can see, your argument would have to be quite compelling presenting new data or a change in the reality of the experience ;-)

Possibly, the solution is to better communicate what that setting does.

comment:4 follow-up: @vanillalounge7 years ago

Sorry about the duplicate ticket, first of all. The consideration was born out of the simple fact that for most of the non US world a date format of "Y/m/d - g:i A" means nothing at all... not to metion the Am/Pm thing.

comment:5 in reply to: ↑ 4 ; follow-up: @lloydbudd7 years ago

Replying to vanillalounge:

Sorry about the duplicate ticket, first of all. The consideration was born out of the simple fact that for most of the non US world a date format of "Y/m/d - g:i A" means nothing at all... not to metion the Am/Pm thing.

Sorry, I don't understand that in the original context that it respects localization. You wrote "I've noticed that on some areas of the dashboard, the dates shown are formatted according to the translation file (<locale>.mo, if it exists)."

comment:6 in reply to: ↑ 5 @vanillalounge7 years ago

Sorry, I don't understand that in the original context
that it respects > localization. You wrote "I've noticed
that on some areas of the dashboard, the dates shown are
formatted according to the translation file (<locale>.mo,
if it exists)."

You're right, it does, my english and my haste are at fault. This started in MU where different users can have different formats but template.php only considers the .mo. Meaning that I was suggesting that each user should see all dates in the format he chose for himself. I can also agree that this whole issue is probably no more than a quibble.

comment:7 @janbrasna7 years ago

  • Cc janbrasna added

This might be more appropriate in http://trac.mu.wordpress.org/ as in most WP instances there's no need for using back–end date format other than the .mo one, contrary to WPMU needs.

comment:8 @Denis-de-Bernardy6 years ago

  • Keywords has-patch needs-testing added; date format time format removed

comment:9 @ryan6 years ago

  • Component changed from Administration to Date/Time
  • Owner anonymous deleted

comment:10 @Denis-de-Bernardy6 years ago

  • Keywords 2nd-opinion added

Imo, this should be closed as invalid. The patch can potentially introduce issues if you set the date format to some very long format.

comment:11 @Denis-de-Bernardy6 years ago

  • Milestone 2.8 deleted
  • Resolution set to invalid
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.