WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#8533 closed defect (bug) (invalid)

Admin Panel Crashes Firefox with use of Paypal's Plugin

Reported by: Saberj Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.7
Component: Administration Keywords: 2.7, RC1, Crash, Firefox, Paypal
Focuses: Cc:

Description

Wordpress 2.7
Windows XP
Firefox 3.0.4

When loading the main page of the Wordpress 2.7 Admin panel, I was getting constant crashes. I disabled all my add-ons for Firefox, then started back through them one by one. I finally determined that Paypal's official plugin (https://www.paypal.com/us/cgi-bin/webscr?cmd=xpt/Marketing_CommandDriven/general/NewPayPalPlugin-outside) was causing the crashes. With it disabled, and everything else enabled, things work fine. But enable it with or without the other plugins, and firefox crashes hard whenever the Admin panel loads.

The plugin is supposed to allow you to autofill shipping/billing address forms on shopping sites, as well as generating virtual debit card numbers for you, in the case that a site you are shopping at doesn't accept paypal. So, it may be trying to determine if the site needs to be pre-filled with data. I'm not good enough to determine what exactly is causing the crash.

However, it happens every time for me. I've asked for other people to help verify this bug, but haven't got anyone to do it just yet. You can see the thread concerning this topic here: http://wordpress.org/support/topic/223400?replies=3

I assume Paypal is going to be a big thing for bloggers that may have donations and such through them. So, making sure the software works with their plugin should be pretty important.

Change History (4)

comment:1 jacobsantos5 years ago

  • Milestone changed from 2.7 to 2.8

Given the almost invalid, external nature of this ticket, I'm moving to 2.8. When you've reached a conclusion on what WordPress can do to resolve this, then come back.

comment:2 DD325 years ago

  • Resolution set to invalid
  • Status changed from new to closed

In the event that its shown that its WordPress causing the issue, then re-open the ticket.

The fact that upon disabling the Paypal extension the crashing stops, shows that its the fault of the extension, and not WordPress. Given that WordPress doesn't access/call the Paypal plugin at all, Means its out of WordPress's control.

The bug needs to be submitted to Paypal so to prevent their Extension from crashing the browser, simple as that. The same can be said for any browser plugin/extension.

comment:3 Saberj5 years ago

This is the only page I've ever seen effect the plugin, so there is obviously something funky going on here specifically with the admin panel and its interaction with the plugin. Just because something isn't completely the fault of the software doesn't mean it shouldn't be looked into. Especially when it's a pretty common plug-in for your target audience. It's similar to how you fix errors that are caused by IE's poor formatting of perfectly good code. Ultimately, I could care less whether you or paypal fixes this bug. But it should at least be documented as occuring somewhere so that when someone gets frustrated because they can't figure out what is happening, they know what is causing it, rather than just assuming that Wordpress 2.7 isn't going to work for them. But, whatever.

comment:4 ryan5 years ago

  • Milestone 2.8 deleted
Note: See TracTickets for help on using tickets.