WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#8543 closed defect (bug) (duplicate)

2.7rc1 Dashboard RSS Won't update some feeds (like the default 'Other Wordpress News' Feed)

Reported by: grassrootspa Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.7
Component: Administration Keywords: dashboard rss feed
Focuses: Cc:

Description

Hey guys,

I've been using Wordpress for years but this is the first time I've seen something like this (Very strange). Have been using Wordpress 2.7rc1 for the past week and noticed that for some reason the RSS dashboard feed will not update new feed items properly in conjunction with http://planet.wordpress.org/feed/

While I have been able to load other feeds from other sites and the dashboard feed sections display the newer items, the Wordpress dashboard RSS WILL NOT show any new "Other Wordpress News" items later than Dec 1 (date I installed 2.7 RC1...did not have this problem with earlier Wordpress versions).

I have tried editing/reentering the RSS url in the dashboard feed item, tried other feeds, etc but this particular feed within the dashboard continues to only show Dec 1 and earlier items.

Obviously I can see this default secondary Wordpress feed (http://planet.wordpress.org/feed/)properly with multiple browsers (and note many new items).

After doing some googling I have noticed other have had similar problems with the Dashboard RSS not displaying some feeds properly.

Attachments (2)

rssfeeddashboard.gif (33.7 KB) - added by grassrootspa 5 years ago.
A Dec 10 screen show (Note 'Other Wordpress News' is stuck at Dec 1.
wp_options.sql (116.3 KB) - added by jick 5 years ago.
Well I just deleted all rss_* rows from my wp_options table and it still exhibits the same issue. So, I don't think it could be an issue in the rss_* rows. But, here is what mine is anyway…

Download all attachments as: .zip

Change History (14)

comment:1 jacobsantos5 years ago

Most likely caching problem of the Dashboard RSS widget.

comment:2 DD325 years ago

I've had this problem as well.

At one stage i had a cached 'Other WordPress News' of >1month old, Cleared the RSS options from the database, and its continued working since.. I stupidly didnt think of saving the contents of the options since i thought it'd happen again if it was indeed a bug.

comment:3 grassrootspa5 years ago

Slight update: I have RC2 installed and still have the RSS dashboard feed problem.

Grrrr, 'Wordpress Development Blog' updated to show 2.7RC2 being released today but 'Other Wordpress News' is STILL stuck in DEC 1!

grassrootspa5 years ago

A Dec 10 screen show (Note 'Other Wordpress News' is stuck at Dec 1.

comment:4 DD325 years ago

  • Component changed from Feeds to Administration
  • Milestone changed from 2.7 to 2.7.1
  • Owner set to anonymous

Bumping to 2.7.1, Since 2.7 is done.

Could you retrieve the rss_ options from the database? Only the data for the problematic feed is needed, but it might be hard to determine which one it is. I'm interested in seeing if its a problem with the cache-timestamps on database insert, or on the output in the widget.

comment:5 jick5 years ago

I think I am experiencing a similar issue. It may be the same one... I just today updated my production site from 2.6.5 to 2.7 final and now there is nothing under Other WordPress News. I have also tried messing with the settings but it's still a no-go. I can grab my rss_ options from my database if requested...

comment:6 sspelta5 years ago

I am experiencing the same issue as described in my ticket #8538

comment:7 jca5 years ago

I have the same problem. I have two installs of 2.7 -- on my own server the feed loads fine, on my Dreamhost hosted WP 2.7 the Other WordPress News RSS feed does not load, but other feeds load fine (as described in the original ticket).

comment:8 DD325 years ago

Can someone please provide the rss_* options from their database (who are affected) in order for someone to be able to reproduce it?

comment:9 grassrootspa5 years ago

I honestly have no clue how to get the 'rss_* options database' info. Can someone explain how one would do this?

Also, would this simply be text I can post here?

Sorry but I am new at this. My email is 'grassrootspa *AT* gmail *DOT* com'

jick5 years ago

Well I just deleted all rss_* rows from my wp_options table and it still exhibits the same issue. So, I don't think it could be an issue in the rss_* rows. But, here is what mine is anyway...

comment:10 strider725 years ago

This bug may be a duplicate of http://trac.wordpress.org/ticket/8495

Should we close this one as a dupe?

comment:12 Denis-de-Bernardy5 years ago

  • Milestone 2.7.2 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

closing as dup of #8495. please re-open with feedback if needed.

Note: See TracTickets for help on using tickets.