WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

Last modified 4 months ago

#8551 closed defect (bug) (invalid)

Localized strings with plural forms (msgid_plural) seem not to work anymore

Reported by: mastermind Owned by: nbachiyski
Milestone: Priority: normal
Severity: normal Version: 2.7
Component: I18N Keywords:
Focuses: Cc:

Description

I don't know if this is an error with my translation, or if something changed (that has worked before). Anyway, it appears that in the current trunk, strings which have plural forms, don't work anymore.

The strings look as follows:
msgid "Tag"
msgid_plural "Tags"
msgstr[0] "Schlagwort"
msgstr[1] "Schlagworte"

In the translated-to-be output, the term "Tag" is not replaced by "Schlagwort".

How to reproduce:

  • Download the attached translation and save it as de_DE.po
  • compile it (e.g. msgfmt -o de_DE.mo de_DE.po)
  • move de_DE.mo to /wp-content/languages/
  • set WPLANG to 'de_DE' in wp-config.php
  • now go to /wp-admin/plugin-install.php in your browser and click the dropdown saying "Suchbegriff". You will see the third entry "Tag", even though it runs through the translation function.
  • The same is visible on /wp-admin/edit-comments.php: The texts "All" and "Approved" above the table should actually read "Alle" and "Freigegeben".

Change History (4)

comment:1 @mastermind7 years ago

I wasn't able to attach the current translation to this ticket due to a server upload limit. Please grab the file from http://svn.automattic.com/wordpress-i18n/de_DE/trunk/messages/de_DE.po.

comment:2 @nbachiyski7 years ago

  • Resolution set to invalid
  • Status changed from new to closed

Some of your translations are fuzzy, that's why they don't show up:

#: wp-admin/includes/dashboard.php:189
#, fuzzy
msgid "Post"
msgid_plural "Posts"
msgstr[0] "Artikel"
msgstr[1] "Artikel"

Open your favourite po editor, fix the translation and make sure it's no longer marked as fuzzy.

comment:3 @mastermind7 years ago

Thanks for pointing this out; I didn't even see that.

But I also don't understand it, I used msgmerge with the -N option, and I only edited the files with kwrite. Seems to be a bug in msgmerge, I think it shouldn't create fuzzy messages with -N at all.

Anyway, you're right. After removing the "fuzzy" markers, everything works.

comment:4 @DrewAPicture4 months ago

  • Milestone 2.7 deleted
Note: See TracTickets for help on using tickets.