WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 6 years ago

Last modified 5 years ago

#8559 closed defect (bug) (duplicate)

Comments on private posts appear in dashboard

Reported by: PeteHoliday Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.7
Component: Comments Keywords:
Focuses: Cc:

Description

Comments added to private posts show up in the dashboard and sidebar widgets regardless of whether or not the user has permission to see the private posts or (in the case of the sidebar widget) is even logged in.

The sidebar widget just shows that the comment exists. In some situations, even the knowledge that the comment (and therefore the private post) exists can be detrimental. The dashboard problem is bigger, though, as the actual text of the comment is displayed.

This behavior appears in both 2.7 RC1 and 2.7 RC2.

Change History (5)

comment:1 @mrmist7 years ago

  • Milestone set to 2.7

Confirmed. The same applies to the edit comment view, which really shouldn't show comments that are on private posts or not yet approved.

comment:2 @DD327 years ago

  • Keywords dev-feedback added
  • Milestone changed from 2.7 to 2.7.1

Bumping to 2.7.1

comment:3 @ryan6 years ago

  • Milestone changed from 2.7.1 to 2.8

comment:4 @mrmist6 years ago

  • Keywords dev-feedback removed
  • Milestone 2.8 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

#9144 has a patch so closing this one as dupe

comment:5 @voyagerfan57615 years ago

  • Cc WordPress@… added
Note: See TracTickets for help on using tickets.