WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#8623 closed defect (bug) (invalid)

Fatal error: Call to undefined function wp_get_current_user() in C:\Vn\wp27\wp-includes\capabilities.php on line 920

Reported by: arena Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Administration Keywords:
Focuses: Cc:

Description

Did any body get this ?

I was just trying to deactivate a plugin ...

Fatal error: Call to undefined function wp_get_current_user() in C:\Vn\wp27\wp-includes\capabilities.php on line 920

What i did after :

1 - Back up the db and my wp.
2 - Removed all my plugins from wp-content/plugins
3 - refreshed the browser => and came back to the admin login page,
4 - Copyed back the plugins,
5 - Try to log in
6 - Same message again ...
7 - Removed all my plugins from wp-content/plugins
8 - Refresh the browser on log in page several times
9 - Tried to log in => successfull

If this can help, wp_get_current_user() is in pluggable.php.
the plugin i was trying to deactivate can have some pluggable functions recoded (settings option) but not this one.

attached file : the backups, if any one wants to replay the bug !

Change History (2)

comment:1 sivel5 years ago

  • Resolution set to invalid
  • Status changed from new to closed

duplicate of #8624

comment:2 johnbillion5 years ago

  • Milestone 2.8 deleted
Note: See TracTickets for help on using tickets.