WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#8643 closed defect (bug) (invalid)

Templates are lost

Reported by: csseur3 Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.7
Component: Template Keywords: templates reporter-feedback
Focuses: Cc:

Description

In WP 2.7, it is impossible to choose a template for a page or a post.

Attachments (1)

Capture.png (16.7 KB) - added by csseur3 5 years ago.
capture of attributes panel (french translation)

Download all attachments as: .zip

Change History (14)

comment:1 ionfish5 years ago

  • Milestone 2.7.1 deleted
  • Resolution set to invalid
  • Severity changed from major to normal
  • Status changed from new to closed

You couldn't choose templates for posts anyway. Templates for pages can be selected from the Attributes panel. If you can't see that panel, check Screen Options on the Add Post page and ensure that it's enabled.

comment:2 csseur35 years ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

Attributes panel are enabled, but i can't choose a template.

comment:3 DD325 years ago

  • Keywords reporter-feedback added

Need a bit more info.

Do you see the Template selection box? If so, Does the option not stick?

Have you tried with all plugins disabled, And the default theme? (Assuming it has some templates)

comment:4 DD325 years ago

(Note, That templates work correctly for me, I'm using them now, So i'm tempted to reclose as worksforme unless you've got alternate source)

comment:5 csseur35 years ago

I use the default theme with only one extension (akismet).

I don't see the Template selection box

I use 5 templates, because before i have created 5 templates under wp 2.6.5 (my installation is an upgrade 2.6.5 > 2.7)

comment:6 mrmist5 years ago

  • Priority changed from high to normal

Is this in a specific browser?

My 2.6.5 -> 2.7 test site is showing the template select just fine from the default theme. Of course if you have a non-stock theme with more templates it could be something about the particular templates that is causing them not to show.

comment:7 csseur35 years ago

i use firefox 3, and i can reproduce the problem on 4 other blogs :/

comment:8 csseur35 years ago

same problem with opera 10 or konqueror.

csseur35 years ago

capture of attributes panel (french translation)

comment:9 mrmist5 years ago

Do your Page templates have the comment in

E.g.

/*
Template Name: Archives
*/

For their name?

comment:10 csseur35 years ago

absolutely, and all of my templates works good on wp 2.6.5

comment:11 filosofo5 years ago

I have seen something like this a couple of times but have been unable to reproduce it in order to track down. The solution for me was to switch to another theme and switch back to the current theme.

comment:12 mrmist5 years ago

The code that generates this has not changed a lot, looks like it was just code cleaning in theme.php since 2.6.5. You could always try swapping out the code in get_page_templates for the 2.6.5 copy.

comment:13 csseur35 years ago

  • Resolution set to invalid
  • Status changed from reopened to closed

Thanks filosofo!

the theme is not really good activated when i switch 2.6.5 > 2.7 and just reactived it and all are good :)

bye

Note: See TracTickets for help on using tickets.