WordPress.org

Make WordPress Core

Opened 11 years ago

Closed 10 years ago

Last modified 10 years ago

#8652 closed task (blessed) (fixed)

Theme browse and install

Reported by: ryan Owned by: ryan
Milestone: 2.8 Priority: normal
Severity: normal Version: 2.8
Component: Themes Keywords: needs-testing
Focuses: Cc:

Description

Theme browser and installer like we do for plugins.

Attachments (8)

8652.diff (42.2 KB) - added by DD32 11 years ago.
8652.2.diff (40.2 KB) - added by DD32 11 years ago.
index.php (12.0 KB) - added by ryan 11 years ago.
server side bits
8652.3.diff (6.4 KB) - added by DD32 11 years ago.
themepopupscreen.jpg (39.5 KB) - added by navjotjsingh 11 years ago.
Theme Popup Screenshot Attached.
8652_textchgs.diff (4.2 KB) - added by MichaelH 11 years ago.
Minor text changes, fix caps
errordetails.jpg (113.6 KB) - added by navjotjsingh 11 years ago.
Theme Error Screenshot Attached.
theme-install-feature-filter.diff (7.8 KB) - added by josephscott 10 years ago.
Replace 'popular tags' section with feature filter

Download all attachments as: .zip

Change History (61)

#1 @ryan
11 years ago

Anyone want to start on this?

#3 @DD32
11 years ago

  • Version set to 2.8

Alright, I'll take a shot at this over the coming week

#4 @DD32
11 years ago

Who do i contact regarding the API? Currently theres a few issues:

  • Null fields
  • Incorrect download URL
  • Missing url's (a Theme preview link would be good)
  • Err.. I'm sure theres something else I've forgotten.
  • Popular view doesnt appear to be showing through via the API
  • A Thumbnail link would be nice..

I'll post a patch up soon which will have the basic items, VERY limited styling (theres absolutely no styling really.. I'd like for the theme/plugin installation/browsers to get a UI overhaul and thats not something up my alley, Jane was going to knock up some mockups, Did that ever happen?

@DD32
11 years ago

@DD32
11 years ago

#5 @DD32
11 years ago

  • Keywords needs-testing added

attachment 8652.2.diff added.

  • First patch contained useless stuff.. and missed version.php
  • Theme install from local zip works
  • Theme install from browser will not work until API is fixed

Not setting to has-patch as its not commit worthy until API issues are resolved, However, Testing is welcome, but be warned its very alpha, and has untested code branches during the install procedure, unless you -really- know what you're doing, i'd advise staying away from this patch until its a bit more stable and useable, and perhaps given some more styling :)

@ryan
11 years ago

server side bits

#6 @ryan
11 years ago

Attached the current server side implementation. I can help with getting it fixed up.

#7 @DD32
11 years ago

Attached the current server side implementation. I can help with getting it fixed up.

Cheers, I'll go through and strip out the undeded bits.. Do you know the list of meta keys that are defined for each theme by any chance? :)

#8 @DD32
11 years ago

If anyones willing to design or code up a UI, it'd be greatly appreciated.

I have very little time on my lands lately.. And just dont have the time to do it.

Ideally, The ability to select tags (say, a list across the top of the page), which then loads theme "boxes" on the page (ie. much like the theme selection page) would be good.

#9 @ryan
11 years ago

(In [10553]) Rough first cut of theme browser/installer. Props DD32. see #8652

#10 @ryan
11 years ago

Landed your patch so we can start iterating.

#11 @DD32
11 years ago

Alright, I've got other modifications locally to that i believe, So:

attachment 8652.3.diff added

Thats nothing special.. I'll outline what i was wanting to achieve with the UI here:

The user being able to select a set of tags (Much like the "Special" tags on .org, 1, 2, 3 column, widget ready, etc.). The API would then return a list of themes with those tags.

Optionally, It could allow for a custom tag to be included, or a search term. But in reality, at present, with the limited number of themes which are returned from these current tags, Search/custom tags can be ignored for now IMO (Maybe introduce them later on or something)

The Themes page, would be very much like the current themes, The top would allow the selection of the themes, And the section below would ajax-load the themes (With a normal HTTP Post fallback for everything). The Theme blocks in the lower section would be just images of the theme (Possibly with name showing through), Upon hover, it'd show the description as well as the links or something.. Clicking the theme would open a plugin-information-like dialogue (but for themes obviously), with all the usual info.. etc.

@DD32
11 years ago

#12 @DD32
11 years ago

Much like the Tag Filter function on Wordpress.org themes.. (Although i'm not sure if thats actually public yet?)

#13 @navjotjsingh
11 years ago

Don't know whether its a bug with the installer of theme's extend website but it is trying to install a older version of atleast one theme which I checked: http://wordpress.org/extend/themes/amazing-grace

To reproduce the bug, search for "right sidebar" tag and try to install the third theme: Amazing Grace ...its showing older version as 1.1 whereas current version is 3.0 and download does not work.

#14 @DD32
11 years ago

Don't know whether its a bug with the installer of theme's extend website

Looks to be a bug in the API, Quite possibly the Extend website stores previous versions too.. it just needs to be changed to select the latest version of the theme or something..

#15 @ryan
11 years ago

(In [10559]) Theme install updates from DD32. see #8652

#16 @ryan
11 years ago

(In [10560]) Theme install updates from DD32. see #8652

#17 @ryan
11 years ago

(In [10567]) UI tweaks to theme installer. see #8652

#18 @ryan
11 years ago

Made some UI tweaks.

  • Move install from .zip to Upload tab
  • Rename Start Page to Search
  • Put tag filter place holder in Search page
  • Remove table from theme list

#19 @ryan
11 years ago

I think our theme listing should resemble the listings on the themes site.

Example:

http://wordpress.org/extend/themes/browse/popular/

#20 @navjotjsingh
11 years ago

Theme Popup window now does not even fit on my screen(I am on 1440x900) resolution and its still fetching old versions of some themes. Pls fix the size of popup, its too big. Moreover rating on popup window does not show...they are shown as vertical and blank. Also no matter whichever theme it is, it shows its version as 1.1. And no matter what the theme, it fetches the file theme.1.1.zip and if it succeeds, its ok otherwise it fails.

I tried this with this two themes.

@navjotjsingh
11 years ago

Theme Popup Screenshot Attached.

#21 @ryan
11 years ago

(In [10590]) Fix preview for theme installer. see #8652

#22 @ryan
11 years ago

(In [10591]) Fix preview link for theme broweser. see #8652

#23 @ryan
11 years ago

(In [10592]) More theme preview tidying. see #8652

#24 @ryan
11 years ago

(In [10650]) Upload theme from zip fixes. see #8652

#25 @ryan
11 years ago

(In [10653]) Try grid layout for theme browser. see #8652

#26 @ryan
11 years ago

(In [10655]) Hide theme details. See #8652

#27 @MichaelH
11 years ago

At 10656, Appearance->Add New Themes, Popular tags, click on a tag, and view the themes in that tag, there is always one, or two, empty theme squares at the very end of the possibilities.

Right now, tag 'yellow' shows two empty squares and tag 'w3c' shows one empty square.

Reporting this here, please advise if you want reports like this on separate tickets.

#28 @navjotjsingh
11 years ago

One more suggestion, now since details come directly under theme name in theme-install page, why not remove install popup completely since it shows nothing new now. And also get rating also display under the details on theme page along with author and version info. That way there is no need for the extra wide popup to come up with install link.

@MichaelH
11 years ago

Minor text changes, fix caps

#29 @ryan
11 years ago

(In [10667]) Text tweaks. Props MichaelH. see #8652

#30 @ryan
11 years ago

(In [10668]) Display more theme info. see #8652

#31 @ryan
11 years ago

(In [10669]) Don't display empty theme. see #8652

#32 @navjotjsingh
11 years ago

Now all themes show this in details:

Last Updated: 14303 days ago

And moreover, link to theme page on extend is nowhere and the popup is unnecessary and should be removed.

#33 @DD32
11 years ago

Last Updated: 14303 days ago

I'm not seeing that at all.

As for the frame, Yes, It'll be removed if it stays as it currently is, Chances are however, That someone will play around with the layout more and possibly change it again, There might be a use for it then, If thats the case, then it makes no point to remove it, then re-implement it.. But yes, It will be removed if it offers nothing useful come finalisation of the UI

@navjotjsingh
11 years ago

Theme Error Screenshot Attached.

#34 @navjotjsingh
11 years ago

Replying to DD32:

Last Updated: 14303 days ago

I'm not seeing that at all.

I have attached a screenshot of the new error.

#35 @DD32
11 years ago

I have attached a screenshot of the new error.

Ah, Seems like the API is returning null for the last updated of some themes

If you view the Latest items, then the days are reported correctly there.

#36 @ryan
11 years ago

(In [10674]) Make sure last_updated is set. see #8652

#37 @ryan
11 years ago

We might offer a flow like preview -> install -> live preview -> activate|delete within the thickbox popup.

#38 @MichaelH
11 years ago

At [10674]

When searching for a new theme, with this Term, "phpto", get this error:
Warning: Invalid argument supplied for foreach() in C:\xampp\htdocs\wp28\wp-admin\includes\theme-install.php on line 396

#39 @ryan
11 years ago

(In [10675]) Bail if no themes found. see #8652

#40 @MichaelH
11 years ago

10675 fixed the problem--thanks Ryan.

When Previewing a theme, say from the themes displayed in Recently Updated, the Preview has an X to cancel, but that should be moved to the right side (as it is for the Install box for Themes and Plugins). Also, consider changing the title (that should move to the left) to say Previewing "theme-xyz".

#41 @ryan
11 years ago

  • Owner set to ryan

#42 @azaozz
11 years ago

(In [10788]) Theme install style tweaks, see #8652

#44 @josephscott
11 years ago

We've been normalizing theme tags (see http://wordpress.org/extend/themes/about/ ), not all themes have been updated for this yet, but the percentage of themes that haven't been are rapidly growing smaller.

#45 @azaozz
11 years ago

(In [10823]) More theme install styling, see #8652

@josephscott
10 years ago

Replace 'popular tags' section with feature filter

#46 @josephscott
10 years ago

Attached a patch to replace the 'popular tags' section of the theme install area with a 'feature filter' capability. The feature filter is more powerful and the popular tags list had tags that have been deprecated.

#47 @DD32
10 years ago

get_option() for the tag cache should be changed to use get_transient() too.

#48 @azaozz
10 years ago

(In [10883]) Theme install: replace 'popular tags' section with feature filter, props josephscott, see #8652

#49 @ryan
10 years ago

(In [10885]) Translate tag filter keywords. see #8652

#50 @ryan
10 years ago

(In [10887]) Make wporg_theme_feature_list a transient. see #8652

#51 @ryan
10 years ago

  • Resolution set to fixed
  • Status changed from new to closed

#52 @hakre
10 years ago

$api->$key now does notices:

Notice: Undefined property: stdClass::$requires in \wp-admin\includes\theme-install.php on line 459

Change in theme api? X-Ref: #12412

#53 @voyagerfan5761
10 years ago

  • Cc WordPress@… added
Note: See TracTickets for help on using tickets.