WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 4 years ago

Last modified 4 years ago

#8665 closed enhancement (wontfix)

Too short timeout for trackbacks and pingbacks

Reported by: tmcookies Owned by:
Milestone: Priority: high
Severity: major Version: 2.7
Component: HTTP API Keywords: dev-feedback
Focuses: Cc:

Description

The timeout for trackback and pingback set on line 201 of wp-includes/cron.php is too short (0.01). I think this is the reason why many servers aren't able to do pingbacks and trackbacks. Maybe this value should be set to 1 or be available in the settings page to change to fit the needs of the server..

The attached diff is a simple fix of the timeout itself.

Attachments (1)

ping_to.diff (412 bytes) - added by tmcookies 7 years ago.
Diff file to change the ping timeout

Download all attachments as: .zip

Change History (19)

@tmcookies7 years ago

Diff file to change the ping timeout

comment:1 @tmcookies7 years ago

  • Keywords has-patch needs-testing dev-feedback added; pingback cron removed

comment:2 @tmcookies7 years ago

  • Keywords changed from has-patch,needs-testing,dev-feedback to has-patch needs-testing dev-feedback

comment:3 @ryan7 years ago

The request is meant to be async so we want a short timeout. Some of our transports might not be handling that well, however. curl, for example, bumps any timeout less than 1 to 1 because it doesn't like floats. Other transports may have a similar problem.

comment:4 @sardisson7 years ago

  • Cc sardisson added

comment:5 @ryan7 years ago

  • Component changed from Comments to HTTP

comment:6 @FFEMTcJ6 years ago

  • Milestone changed from 2.7.2 to 2.8

Postponing enhancements to 2.8. Is this a won't fix?

comment:7 @ShaneF6 years ago

  • Keywords commit added

+1, but at a value of 0.5.

I see this on a number of servers that limit php ability to use HTTP queries, but most do not have this problem. Setting this to high could cause major backlog problems.

comment:8 @ShaneF6 years ago

  • Keywords needs-testing removed

comment:9 @ryan6 years ago

  • Keywords has-patch commit removed

Transports that can't handle < 1 second need to be updated. Transports to do support this should retain 0.01.

comment:10 @luziferus6 years ago

  • Cc luziferus added

I've seen multiple wp-blogs not working fine with timeout of 0.01 seconds so they needed to patch up the time. Mostly it is not possible to change the hardware / transport / whatever so there has to be a solution on software side.

Thats the reason I would definitly increase this value. One has to try out how much is needed and how much is possible without slowing down everything. For me personally one second is working very fine and everyone else giving feedback to my hint confirmed this.

So please increase this limit in the earliest future release / update to get the pingbacks working without manually patching of the files.

comment:11 @ryan6 years ago

What transports does your blog use? You can find out with this plugin:

http://core.trac.wordpress.org/attachment/ticket/9078/list_transports.php

comment:12 @Denis-de-Bernardy6 years ago

would be sweet to commit or wontfix, so that we can trim the > 1k bug list...

comment:13 @DD326 years ago

I doubt the timeout is going to be increased. Theres simply no need for it. However, Any transports which are not handling properly with a low connection timeout do need to be updated, Like Ryan said.

Unfortunately, Patchers cant tell what is causing it on the target system without actually getting feedback, Without feedback, We cant reproduce, AFAIK, this hasnt been reproduced either, other than with Curl which was fixed..

comment:14 @Denis-de-Bernardy6 years ago

  • Milestone 2.8 deleted
  • Resolution set to wontfix
  • Status changed from new to closed

let's close as wontfix until reporters re-open with feedback.

comment:15 @techecatocom6 years ago

  • Cc techecatocom added

comment:16 @yogieanamcara4 years ago

  • Resolution wontfix deleted
  • Status changed from closed to reopened
  • Version changed from 2.7 to 3.1

Still the same issue on my WP Multisite in WP 3.1?

comment:17 @yogieanamcara4 years ago

  • Resolution set to wontfix
  • Status changed from reopened to closed

comment:18 @hakre4 years ago

  • Version changed from 3.1 to 2.7

Please don't change the number the ticket was originally reported against for no reason. Thanks.

Note: See TracTickets for help on using tickets.