WordPress.org

Make WordPress Core

Opened 11 years ago

Closed 11 years ago

#8694 closed defect (bug) (fixed)

Word 2007 can't retrieve categories

Reported by: Dezl0ck Owned by: josephscott
Milestone: 2.7.1 Priority: low
Severity: normal Version: 2.7
Component: XML-RPC Keywords:
Focuses: Cc:
PR Number:

Description

After upgrading to Wordpress 2.7, Microsoft Word 2007 is not able to retrieve categories from the server. When in Word, click Insert Category and authenticate to your WP installation. The attempt will appear to be successful, but the Categories drop down box in Word is empty.

Change History (2)

#1 @josephscott
11 years ago

This was probably caused by a change we made in the 2.7 release for the metaWeblog.getCategories method. We've adjusted that change in the 2.7 branch because of concerns that clients like this would break. Try the lastest version of the xmlrpc.php file for the 2.7 branch:

http://svn.automattic.com/wordpress/branches/2.7/xmlrpc.php

that should fix the problem. This fix will be part of 2.7.1 when it comes out.

#2 @thee17
11 years ago

  • Milestone set to 2.7.1
  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.