WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#8711 closed defect (bug) (duplicate)

Certain posts can disappear from the edit view

Reported by: king76 Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.7
Component: General Keywords:
Focuses: Cc:

Description

Hi,

I have a post with 19 images (gif, png ..), after submit, my textarea is empty ! I must to delete 2, 3 images (total 15) and the save is correct

Do you know this bug ?

Please see my attach file for example

Attachments (1)

blogue (9.6 KB) - added by king76 5 years ago.
example html for simulate bug

Download all attachments as: .zip

Change History (6)

king765 years ago

example html for simulate bug

comment:1 mrmist5 years ago

  • Summary changed from more of 15 images ! to Certain posts can disappear from the edit view

I tested with the attached and did not see the issue.

However, I have seen this before. It happens with a certain combination of long text and characters. I believe the "more" tag may have something to do with it. Posts that have lines of dashes seem to fall into it, but I've not yet been able to reliably reproduce the problem. I am not convinced that it is anything particularly to do with the number of images.

Could be a tricky one to pin down, I'll see if I still have the article text I used before to reproduce.

Edited summary.

comment:2 DD325 years ago

mrmist: Such things happen with preg_replace, Long strings, and php's builtin backtrace limit, If the backtrace limit is hit, then it returns a empty string. Theres a number of bugs around on that..

I think this might be the same issue as #8553 (preg_replace_callback in do_shortcode returns empty for large posts) since they both deal with shortcodes (The number of images means the number of caption shortcodes in use)

comment:3 mrmist5 years ago

Ahh. That other bug could be the issue, then. This is potentially a dupe.

I did find the text that I could use to reproduce the problem.

comment:4 mrmist5 years ago

Yep, my sample text is ok with the workaround for the other bug, so is a dupe of that. I can't speak for the OP on this bug but I guess it is the same thing.

comment:5 mrmist5 years ago

  • Milestone 2.8 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Dupe of #8553

Note: See TracTickets for help on using tickets.