WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#8713 closed enhancement (fixed)

Change "go back" link to "view page" when Page is published.

Reported by: janeforshort Owned by: bingorabbit
Milestone: 2.8 Priority: normal
Severity: normal Version: 2.8
Component: UI Keywords:
Focuses: Cc:

Description

When a Page is created or updated, the alert at the top of the page says "Page updated. Continue editing below or /go back/." Go back is a link to /wp-admin. To match the way we handle published/updated posts, go back should be changed to "view page" with a link to the live page.

Attachments (5)

8713.patch (818 bytes) - added by bingorabbit 5 years ago.
Instead of Go Back and pointing to the referring URL after editing the page, it now says View it and points to the page's URL.
8713.2.patch (820 bytes) - added by bingorabbit 5 years ago.
Changed the View it to View Page.
8713.3.patch (1.0 KB) - added by bingorabbit 5 years ago.
Now you can Go back, or view tha page.
8713.post.patch (1.0 KB) - added by bingorabbit 5 years ago.
For the Edit Posts page.
8713.post-page.patch (1.7 KB) - added by bingorabbit 5 years ago.
View the page/post online after it's editted with no go back link.

Download all attachments as: .zip

Change History (25)

comment:1 Denis-de-Bernardy5 years ago

alternatively, could we add both, when the two urls aren't the same?

comment:2 janeforshort5 years ago

Since user now stays on the actual editing screen after post is published, there is no "go back," which used to be there to take user back to editing screen.

comment:3 bingorabbit5 years ago

This only happens when the page is updated, when it's first published, it works just fine and the link appears saying View Page pointing to the Page's actual URL.

bingorabbit5 years ago

Instead of Go Back and pointing to the referring URL after editing the page, it now says View it and points to the page's URL.

comment:4 bingorabbit5 years ago

  • Cc bingorabbit added

comment:5 bingorabbit5 years ago

  • Keywords has-patch added
  • Resolution set to worksforme
  • Status changed from new to closed
  • Version changed from 2.7 to 2.8

comment:6 bingorabbit5 years ago

  • Resolution worksforme deleted
  • Status changed from closed to reopened

bingorabbit5 years ago

Changed the View it to View Page.

comment:7 williamsba5 years ago

  • Cc brad@… added

Patch 8713.2 tested and working. Tested on nightly build

comment:8 williamsba5 years ago

  • Keywords tested added

comment:9 Denis-de-Bernardy5 years ago

big -1 on this patch.

when editing pages in series, the last thing I'd want is that the link points to the edited page. I'd rather it return me to the edit pages screen, where I come from.

alternatively, it should be consistent with the save posts behavior. if both always point to the post or page that got saved, fine. but it should be the same behavior.

a last option could be to scrap the link altogether. after all, there is a preview button.

comment:10 janeforshort5 years ago

The intended behavior for both posts and pages is that on publish/update, user stays on the edit screen and alert appears that says post/page has been published/updated with link to view post/page. The preview button is not adequate due to the way it currently functions (if you start editing typos, for example, you will preview the changes, not the view the live post/page). While we can certainly look at this overall behavior for future versions, for now we just need to get rid of the 'go back' link that is leftover from 2.5.

comment:11 bingorabbit5 years ago

  • Owner set to bingorabbit
  • Status changed from reopened to new

We can do both, I will work on a patch that integrates the "Go back" link with the "View page" one. So both patches will be available and the Core developers can see what appropriate.

bingorabbit5 years ago

Now you can Go back, or view tha page.

bingorabbit5 years ago

For the Edit Posts page.

comment:12 janeforshort5 years ago

Go back to where? When you publish or update a page, you are still on the editing screen. There should not be a go back link at all, as there is nowhere to go back that the back button won't take you. The "go back" language was made obsolete in 2.7 when the behavior changed.

bingorabbit5 years ago

View the page/post online after it's editted with no go back link.

comment:13 Denis-de-Bernardy5 years ago

  • Keywords commit added

+1

comment:14 ryan5 years ago

Go back takes you back to edit.php if you come from there or the permalink page if you come from there. Seems handy to me.

comment:15 ryan5 years ago

Most all of these messages could be consolidated into one that says, "Post updated. Continue editing below, view the post, or edit another post." Handles linking to edit.php and permalink page.

comment:16 Denis-de-Bernardy5 years ago

  • Keywords tested commit removed

makes sense.

comment:17 Denis-de-Bernardy5 years ago

  • Keywords needs-patch added; has-patch removed

comment:18 ryan5 years ago

(In [11159]) Clean up save mssage. see #8713

comment:19 ryan5 years ago

That guts the referrer junk. We can play with the messages.

comment:20 Denis-de-Bernardy5 years ago

  • Keywords page link view needs-patch removed
  • Resolution set to fixed
  • Status changed from new to closed

in r11159, or then I missed something.

Note: See TracTickets for help on using tickets.