WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#8728 closed defect (bug) (duplicate)

All Comment Permalinks Broken

Reported by: miqrogroove Owned by:
Milestone: Priority: high
Severity: major Version: 2.7
Component: Comments Keywords:
Focuses: Cc:

Description

When themes use wp_list_comments() all of the comment permalinks are in the form of /slug/comment-page-/#comment-206 where a page number is missing from the link, thus breaking all permalinks. To the best of my understanding, that function calls on Walker_Comment::start_el() at some point, where get_comment_link() is used with only one parameter, which appears to be wrong.

A workaround exists as follows: Browse to Dashboard > Settings > Discussion > Other comment settings > Break comments into pages, then clear that check box and save.

Change History (2)

comment:1 @miqrogroove6 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Please mark as duplicate of #8583 Thanks ;)

comment:2 @mrmist6 years ago

  • Milestone 2.7.1 deleted
Note: See TracTickets for help on using tickets.