WordPress.org

Make WordPress Core

Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#8735 closed defect (bug) (duplicate)

The function the_content_rss() is not working

Reported by: spstieng Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.7
Component: General Keywords: the_content_rss
Focuses: Cc:

Description

The function the_content_rss() does not output any data.
It has not been working since I installed WP in june 2008.

The error lies in the '$content = apply_filters('the_content_rss', $content);'
Commenting out this makes the function work.

See http://wordpress.org/support/topic/192997 for more information.

Change History (4)

#1 @spstieng
12 years ago

  • Cc spstieng added
  • Summary changed from the_content_rss not working to The function the_content_rss() is not working

#2 @glycoknob
12 years ago

This also breaks rss comment feeds with umlauts. in the <description> field html entity is used when the function is active.

#3 @mrmist
12 years ago

  • Milestone 2.8 deleted
  • Resolution set to duplicate
  • Severity changed from major to normal
  • Status changed from new to closed

Covered by #8706 I believe

#4 @glycoknob
12 years ago

I solved the problem for me. it turned out to be not a wordpress bug. It was caused by an old broken plugin. see http://www.4null4.de/65/cleanumlauts-plugin-for-wordpress-revisited/ here (german). I'm sorry.

Note: See TracTickets for help on using tickets.