WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#8808 closed defect (bug) (fixed)

If publish_future_post is called before its time, It creates a duplicate entry

Reported by: DD32 Owned by: ryan
Milestone: 2.8 Priority: normal
Severity: trivial Version: 2.8
Component: General Keywords: needs-testing
Focuses: Cc:

Description

when the publish_future_post hook is called, ahead of its time, it'll attempt to cancel the current scheduled event, and schedule another, However, at present, this fails to work 100%

The issue is, That the $args need to match exactly, the event is originally scheduled with array( (string)$ID ), however, the clear/reschedule gets called with array( (int)$ID) which causes the cron ID key to differ slightly, which results in the first schedule not being canceled, and a duplicate schedule being created (with an int as the ID instead of the ID as a string)

(In addition to that, It seems the clear schedule call isnt passed a array too, which results in the key being different again..)

The $ID gets set to a int, thanks to get_post() accepting the ID by reference, and then typecasting it to an int.

The attached patch typecasts it to a string as well as wrapping it in the missing array()

In normal working environments, this shouldn't occur at all, and if it does, the schedule will be duplicated only once due to the 2nd and future sharing the same key.

Attachments (1)

8808.diff (1.1 KB) - added by DD32 5 years ago.

Download all attachments as: .zip

Change History (9)

DD325 years ago

comment:1 DD325 years ago

  • Keywords has-patch added

comment:2 DD325 years ago

any traction..?

comment:3 ryan5 years ago

  • Owner changed from anonymous to ryan

comment:4 Denis-de-Bernardy5 years ago

apparently not much. :-)

comment:5 Denis-de-Bernardy5 years ago

Patch applies cleanly against today's trunk.

comment:7 westi5 years ago

  • Keywords needs-testing added; has-patch removed

[11282] may have fixed this.

comment:8 ryan5 years ago

  • Resolution set to fixed
  • Status changed from new to closed

I think it does.

Note: See TracTickets for help on using tickets.