WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#8820 closed defect (bug) (invalid)

Bag in WP 2.7 - problem with rights (5 posts)

Reported by: mgtuga Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.7
Component: General Keywords:
Focuses: Cc:

Description

Pak Version: WordPress 2.7

Create a user through the administrator. Vests it right - "Contributor". Go to the user rights "party" to the administrative cabinet and choose - "Record" -> "Change." A window "Edit record", which is a pop-up window with items: "Actions", "Edit", "Delete" - respectively, for the rights of these actions are not functioning. The problem is that these actions to the user with such rights should not be.


http://img223.imageshack.us/my.php?image=dsfgdfgwq2.jpg

BIG THX

Attachments (1)

dsfgdfg.JPG (10.1 KB) - added by mgtuga 6 years ago.

Download all attachments as: .zip

Change History (6)

@mgtuga6 years ago

comment:2 @ryan6 years ago

Authors and Contributors should not not be able to load users.php at all.

comment:3 @mrmist6 years ago

Reading the thread I think this is about authors and contributors not being able to edit posts made by admin, but I could be wrong.

comment:4 @mrmist6 years ago

Or something to do with the bulk edit menu options.

I'm testing the screen myself though and it works as I would expect it to.

comment:5 @azaozz6 years ago

  • Milestone 2.8 deleted
  • Resolution set to invalid
  • Status changed from new to closed

This ticket seems to refer to the Edit Posts screen where the bulk actions Edit and Delete are available to contributors from the drop-down.

Since contributors can edit and delete their own posts, this is intentional. Other posts cannot be selected for these actions as they don't have a checkbox.

Note: See TracTickets for help on using tickets.