Make WordPress Core

Opened 7 years ago

Closed 7 years ago

#8825 closed defect (bug) (duplicate)

gzip'ed RSS feeds are not gzinflate()'d

Reported by: dfulbright Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.7
Component: HTTP API Keywords:
Focuses: Cc:


RSS feeds, added using the RSS widget, which are sent from the remote server using gzip encoding, are not properly gzinflate()'d. For example, if you add this feed:


You will get this error when loading the page with the widget:

An error has occurred; the feed is probably down. Try again later.

Attachments (1)

patch.txt (475 bytes) - added by dfulbright 7 years ago.
Patch to gzinflate() RSS feeds if needed.

Download all attachments as: .zip

Change History (3)

7 years ago

Patch to gzinflate() RSS feeds if needed.

#1 @DD32
7 years ago

See #8674 (Support compressed streams in the HTTP API)

Whilst it doesn't have a patch yet, I'm pretty sure Jacob has been working on a patch to support the multiple compression methods which servers incorrectly return. Adding that gzinflate() inside the HTTP API might be better..

#2 @jacobsantos
7 years ago

  • Component changed from General to HTTP
  • Keywords rss gzip removed
  • Milestone 2.7.1 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #8674. It is doubtful that Gzip support will be added to WordPress 2.8, but okay. If enough people support it, then it might.

Note: See TracTickets for help on using tickets.