WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#8834 closed defect (bug) (invalid)

Flash Banner Not Displaying Under archive.php or author.php

Reported by: pypo Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.7
Component: General Keywords: flash
Focuses: Cc:

Description

I have a flash banner embedded in a the sidebar. It works fine under 2.6 but not under 2.7.

Additional details:

Under 2.7 the flash only displays on the home page (home.php) and the search page (search.php).

Under 2.7 the flash does not display on the archives page (archive.php) nor the author page (author.php).

I put the home.php code into archive.php, but the flash still wouldn't play.

I put the archive.php code into home.php, and the flash played okay.

Site is: contractmanagement.us

Change History (5)

comment:1 follow-up: @DD327 years ago

  • Milestone 2.7.1 deleted
  • Resolution set to invalid
  • Status changed from new to closed

Please direct all support queries to the WordPress.org support forums

comment:2 in reply to: ↑ 1 @pypo7 years ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

Replying to DD32:

Please direct all support queries to the WordPress.org support forums

Why is this not a bug? There is nothing on the support forum to address this issue. Please describe why it was closed.

Thanks.

comment:3 @pypo7 years ago

  • Resolution set to invalid
  • Status changed from reopened to closed

comment:4 @filosofo7 years ago

Replying to pypo:

Why is this not a bug?

Trac tickets have to do with core WordPress functionality. Core WordPress does not have Flash banners in its themes' sidebars and doesn't make any claims to support it one way or the other.

And most likely, upgrading 2.7 is not the true cause of your problems, as someone would probably point out at the support forum. Someone might point out, for example, that your Flash object has a relative path ( src="wp-content/ads/run_300x250.swf"). So of course it will work only on the home or search pages, because elsewhere the permalinks make browsers think the Flash file is in a non-existent directory, e.g. the relative URL gets translated into the non-existent http://contractmanagement.us/category/applications/wp-content/ads/run_300x250.swf path when you're on the http://contractmanagement.us/category/applications/ page.

Someone on the support forum would probably say that you need to fix the code you're using to run your Flash banner and that this problem likely started when you activated the "pretty" permalinks.

comment:5 @pypo7 years ago

filosofo: That's what I needed to know. Now I can fix it. Thank you very much.

Note: See TracTickets for help on using tickets.