WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#8854 closed defect (bug) (fixed)

Wordpress relies on server timezone.

Reported by: Appletalk Owned by:
Milestone: 2.8 Priority: normal
Severity: normal Version:
Component: Date/Time Keywords:
Focuses: Cc:

Description

Strict Standards: mktime() [function.mktime]: It is not safe to rely on the system's timezone settings. Please use the date.timezone setting, the TZ environment variable or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/Buenos_Aires' for 'ARST/-2.0/DST' instead in /Users/willy/Sites/Wordpress/2.7/wp-includes/functions.php on line 41

Change History (3)

comment:1 @MattyRob6 years ago

  • Milestone changed from 2.7.1 to 2.8
  • Priority changed from high to normal

You'll be seeing this because your php.ini file is set up to report E_STRICT notices.

These are not programatic errors but notices that the authors of PHP feel there is a better way to do these things.

Certainly this is somethign to look at but it won't get fixed in a point release so moving to 2.8

comment:2 @ryan6 years ago

  • Component changed from General to Date/Time
  • Milestone changed from 2.8 to Future Release
  • Owner anonymous deleted

comment:3 @Denis-de-Bernardy6 years ago

  • Milestone changed from Future Release to 2.8
  • Resolution set to fixed
  • Status changed from new to closed

should be fixed in trunk since r11128

Note: See TracTickets for help on using tickets.