WordPress.org

Make WordPress Core

Opened 15 years ago

Closed 15 years ago

Last modified 4 years ago

#888 closed defect (bug) (fixed)

Image upload produced invalid code

Reported by: dantekgeek Owned by: ryan
Milestone: Priority: normal
Severity: major Version: 1.5
Component: Administration Keywords:
Focuses: Cc:
PR Number:

Description

Whenever I upload an image, I get an incorrect image tag. Looks like this:
<img src='; http://www.intarweb-master.com/wp-content/apple_orange.jpg' alt='hkhkjh' />
I have been able to reproduce this multiple times.

Change History (4)

#1 @dantekgeek
15 years ago

  • Patch set to No

#2 @sidvorak
15 years ago

Looks like there is a stray semi-colon here (upload.php line 203):

if ( ereg('image/',$img1_type) )

$piece_of_code = "<img src=';". get_settings('fileupload_url') ."/$img1_name' alt='$imgdesc' />";

else

Change to:

if ( ereg('image/',$img1_type) )

$piece_of_code = "<img src='". get_settings('fileupload_url') ."/$img1_name' alt='$imgdesc' />";

else

edited on: 02-17-05 22:12

#3 @ryan
15 years ago

  • fixed_in_version set to 1.5
  • Owner changed from anonymous to rboren
  • Resolution changed from 10 to 20
  • Status changed from new to closed

This ticket was mentioned in Slack in #design by celloexpressions. View the logs.


4 years ago

Note: See TracTickets for help on using tickets.