WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 6 years ago

Last modified 4 months ago

#8891 closed defect (bug) (worksforme)

feed=comments-rss2: XML Parsing Error: not well-formed

Reported by: jidanni Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Feeds Keywords:
Focuses: Cc:

Description

Gentlemen, I have accomplished my first vanilla install of Wordpress, 2.7.

We notice these two links on the front page:

$ w3m -dump http://localhost/articles/|grep RSS
Entries (RSS) and Comments (RSS).

http://localhost/articles/?feed=rss2 is fine, but
http://localhost/articles/?feed=comments-rss2 won't show the one
comment present when clicked in firefox. Further probing reveals

$ GET http://localhost/articles/?feed=comments-rss2 > com.xml
$ firefox com.xml

XML Parsing Error: not well-formed
Location: file:///tmp/com.xml
Line Number 18, Column 45:
		<link>http://localhost/articles/?p=1&cpage=1#comment-1</link>
----------------------------------------------------------^

By the way, the top of feed=comment-rss2 that file is also uglier than
feed=rss

<?xml version="1.0" encoding="UTF-8"?><rss version="2.0"

There should be a line break at ><.

Change History (6)

comment:1 @jidanni7 years ago

Also from the home page we click on http://localhost/articles/?p=1 which leads us to http://localhost/articles/?feed=rss2&p=1 , which has the exact same problem. Note all the above is on a totally vanilla installation.

comment:2 @jidanni7 years ago

  • Cc jidanni@… added

comment:3 @peaceablewhale6 years ago

  • Keywords reporter-feedback added

Hello,

I can't reproduce the issue with the latest trunk. It may have been fixed. The link generated is currently ?p=3&#038;cpage=1#comment-2.

Could you check the issue again?

comment:4 @jidanni6 years ago

I'm sorry but I'm now retired from wordpress and forgot everything...

comment:5 @peaceablewhale6 years ago

  • Keywords reporter-feedback removed
  • Resolution set to worksforme
  • Status changed from new to closed

comment:6 @DrewAPicture4 months ago

  • Milestone 2.8 deleted
Note: See TracTickets for help on using tickets.