WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

#8898 closed defect (bug) (invalid)

wp-admin/themes.php: picking classic theme difficult

Reported by: jidanni Owned by:
Milestone: Priority: lowest
Severity: trivial Version: 2.7
Component: Themes Keywords:
Focuses: Cc:

Description

OK, today we are in wp-admin/themes.php, confronted by two choices.

We wan't to try the other theme, so we click
http://localhost/articles/?preview=1&template=classic&stylesheet=classic&TB_iframe=true&width=898&height=513
and it looks nice... but how to make it permanent?!

All the clicking one can do here on themes.php will apparently only get one "previews". There is no button to make one's choice permanent. Nor are the choices offered labeled as "preview". One must infer that from the URL.

OK way below we see

Get More Themes

You can find additional themes for your site in the WordPress theme directory. To install a theme you generally just need to upload the theme folder into your wp-content/themes directory. Once a theme is uploaded, you should see it on this page.

I see, we need to move some folder around. But that is for "more themes", not the two offered, so the user thinks. Also he clicks the tiny Help button, but that just gives a link to the whole Codex, not to the exact article.

Anyway, I'm very happy with the default theme. I'm just saying many users can't figure out how to activate the other they way the page is written.

Change History (7)

comment:1 @DD327 years ago

  • Version set to 2.8

Once a user figures it out the first time, They'll always know how.

Click the theme, View Preview, Click "Activate" in the location where the close button would usually be.

Unless.. You're running with Javascript off, In which case, You most likely would be very confused..

comment:2 @mrmist7 years ago

  • Version changed from 2.8 to 2.7

Is this really a problem? I don't recally seeing that many support threads asking how to activate a theme.

Maybe just a quick line change so that it says

Available Themes - Click on a theme picture to preview it.

Or whatnot, but to be honest it's a mess then because you can get trapped in syntactical constructs, are you clicking to preview or clicking to preview then activate or blah blah blah you get the idea it could just make it even more confusing.

There should probably be alt text on the theme preview images, though.

Version was set to 2.8? I thought version reflects the version the problem is in, so I've put it on 2.7.

comment:3 @jidanni7 years ago

Gentlemen, thank you for your replies, which I do not get mail from,
because I am not on the Cc list, because your TRAC is so special so
one needs to put themselves on the Cc list...

Anyway, here in Firefox on GNU/Linux, it turns out one has to turn OFF
javascript, before the "Preview Activate" link pairs are revealed!

comment:4 @DD327 years ago

Gentlemen, thank you for your replies, which I do not get mail from, because I am not on the Cc list, because your TRAC is so special so one needs to put themselves on the Cc list...

Odd... It should automatically email you.. As long as you've got your email in the settings page: http://trac.wordpress.org/settings

Anyway, here in Firefox on GNU/Linux, it turns out one has to turn OFF javascript, before the "Preview Activate" link pairs are revealed!

Yes, Because those are the non-js fallback links, If you have JS enabled, Clicking on a theme, Opens a new dialogue, In that dialogue, You'll see the Preview (Note: Opening in a new tab/window will NOT work) with a "Activate {theme name}" in the upper right, and a cancel button in the upper left. Its a Thickbox display window.

If you do not see that, Do you have any errors showing in the Firefox error window? or error console, where ever FF logs JS errors basically..

comment:5 follow-up: @jidanni7 years ago

(OK as per Bug #8890 I'm getting your changes now in mail, starting today.)

Ah, I see it, there hiding in drab colors in the black border!

Well, I would make it orange blinking or something, else many people won't notice it.

comment:6 in reply to: ↑ 5 @mrmist7 years ago

Replying to jidanni:

Well, I would make it orange blinking or something, else many people won't notice it.

-1 to anything orange or blinking. ;)

comment:7 @jacobsantos7 years ago

  • Milestone 2.8 deleted
  • Resolution set to invalid
  • Status changed from new to closed

Good luck on this. I think the "activate" is pretty easy to understand. If you can't see it, or can't understand it, then it is good to ask the support forums for help.

Note: See TracTickets for help on using tickets.