WordPress.org

Make WordPress Core

Opened 12 years ago

Closed 12 years ago

#8907 closed defect (bug) (wontfix)

Clicking "Add" button on tag field adds "Add new tag" as a tag

Reported by: IainPurdie Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.7
Component: UI Keywords: tag
Focuses: Cc:

Description

Simple to reproduce:

1) Create / edit a post.
2) Go to the tag field
3) Don't enter anything in the "empty" tag box
4) Click the "Add" button
5) The tag "Add new tag" is added to the post! This is the text which is, by default, in the tag box.

Change History (8)

#1 @bi0xid
12 years ago

Yes, I realized too.

But we cannot do more with input tag. If you have a try, in http://wordpress.org you can hit 'Go' in the upper right corner, and it will search Search WordPress.org.
It will do the same in all search boxes because input value string is the default string if none is written.

We are using this property to add some style or info to the boxes, and it's the price.

Maybe we could use a hover div, but search boxes and tag boxes are not intented to be empty when hitting submit.

#2 @mrmist
12 years ago

It's a quirky little bug for sure, in so far as you only get it if you deliberately choose to really.

The parser could always silently drop "Add new tag" if someone tries to add it, but then there'd be some person somewhere who wanted to add "Add new tag" as a tag.

#3 @MattyRob
12 years ago

Is this really a bug? Or are we trying to overcomplicate things to compensate for incorrect user input?

#4 @sushubh
12 years ago

personally, i think this is an issue. i googled for this and found a lot of blogs are having this tag on their blogs apparently by mistake. just my opinion. had come here to report it myself.

#5 @FFEMTcJ
12 years ago

Am I missing something? I don't see an "Add" button anywhere near the tag field on the post page.

#6 @FFEMTcJ
12 years ago

I don't have it on mine due to a plugin.

#8 @Denis-de-Bernardy
12 years ago

  • Milestone 2.7.2 deleted
  • Resolution set to wontfix
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.